You are not logged in.

#1 2023-09-11 09:45:17

smart2128
Member
Registered: 2010-04-09
Posts: 14

ppp 2.5.0 breaks networkmanager-fortisslvpn and openfortivpn

After ppp's upgrade to version 2.5.0, I'm not able to establish VPN tunnels anymore.
Adding ipcp-accept-remote to /etc/ppp/options, tunnels are established, but remote networks are still unreachable.
Downgrading ppp to version 2.4.9 and removing the ipcp-accept-remote option allows openfortivpn to work again, but networkmanager-fortisslvpn depends on ppp 2.5.0 and has been recently moved to AUR.

Last edited by smart2128 (2023-09-11 09:55:18)

Offline

#2 2023-09-11 16:48:59

Terseus
Member
Registered: 2007-04-26
Posts: 10

Re: ppp 2.5.0 breaks networkmanager-fortisslvpn and openfortivpn

You're not alone, I have the same problem after upgrading today.

I've posted this problem in the networkmanager-fortisslvpn package AUR's page, just in case you want to follow it: https://aur.archlinux.org/packages/netw … ent-933331

Offline

#3 2023-09-12 04:59:51

Utini
Member
Registered: 2015-09-28
Posts: 452
Website

Re: ppp 2.5.0 breaks networkmanager-fortisslvpn and openfortivpn

Yup +1 here


Setup 1: Thinkpad T14s G3, 14" FHD - R7 6850U - 32GB RAM - 2TB Solidigm P44 Pro NVME
Setup 2: Thinkpad X1E G1, 15.6" FHD - i7-8850H - 32GB RAM - NVIDIA GTX 1050Ti - 2x 1TB Samsung 970 Pro NVME
Accessories: Filco Majestouch TKL MX-Brown Mini Otaku, Benq XL2420T (144Hz), Lo(w)gitech G400, Puretrak Talent, Sennheiser HD800S + Meier Daccord FF + Meier Classic FF

Offline

#4 2023-09-14 13:50:50

niki
Member
Registered: 2023-01-20
Posts: 1

Re: ppp 2.5.0 breaks networkmanager-fortisslvpn and openfortivpn

Try uncommenting ipcp-accept-remote in /etc/ppp/options
It worked for me

Last edited by niki (2023-09-14 16:05:55)

Offline

#5 2023-09-16 12:42:29

smart2128
Member
Registered: 2010-04-09
Posts: 14

Re: ppp 2.5.0 breaks networkmanager-fortisslvpn and openfortivpn

niki wrote:

Try uncommenting ipcp-accept-remote in /etc/ppp/options
It worked for me

As I wrote in my post, I already tried it.
The VPN tunnel goes up and the routing table is properly populated, but there is no communications with remote networks/hosts.
After downgrading ppp to version 2.4.9, openfortivpn's client works as expected, but networkmanager-fortisslvpn fails to build without ppp 2.5.0.

Offline

#6 2023-10-05 14:32:05

fatmike
Member
Registered: 2015-01-16
Posts: 3

Re: ppp 2.5.0 breaks networkmanager-fortisslvpn and openfortivpn

niki wrote:

Try uncommenting ipcp-accept-remote in /etc/ppp/options
It worked for me

I can confirm. Using ppp=2.5.0-1 and uncommenting the above setting works for me with openfortivpn.

Offline

#7 2023-10-17 11:09:58

tammar96
Member
Registered: 2023-10-17
Posts: 1

Re: ppp 2.5.0 breaks networkmanager-fortisslvpn and openfortivpn

I can confirm as well.

fatmike wrote:
niki wrote:

Try uncommenting ipcp-accept-remote in /etc/ppp/options
It worked for me

I can confirm. Using ppp=2.5.0-1 and uncommenting the above setting works for me with openfortivpn.

Offline

Board footer

Powered by FluxBB