You are not logged in.

#1 2023-09-14 23:35:44

Registered: 2023-09-14
Posts: 4

Macbook Pro 11,5 (2015): No internal speaker/mic

Hi all,

I've just freshly installed Arch + LXQt on a Macbook Pro 11,5 from 2015.

Unfortunately, I can not get any output from the internal speakers or input from the built in microphone for the life of me.

I've installed nearly every ALSA package at this point, tried both Pulseaudio and Pipewire, but there's no sound.

I can however either attach an HDMI TV with speakers or headphones via the audio jack and get sound over those outputs (although ALSA always mutes them first when added).

Pavucontrol detects an output gauge whenever I'm playing something, but there seems to be some issue "relaying" that sound to the speakers.

I've installed the sof-firmware package and set the Intel PCH card as the default device in asound.conf, but still, nothing. I also booted up a Debian LXQt live system to see if the speakers were broken, but all inputs/outputs and dynamic switching worked on there.

There seems to be something wrong with my config, but I'm a bit in over my head here. What could be the issue?


I reinstalled the system with the default configuration after reading this issue and thinking it was a KDE/XLQt-related problem: … replumber/

This worked one time, however after a reboot, the internal speakers/mic were gone again.

I then tried to create the file /etc/modprobe.d/alsa-base.conf with the content "options snd-hda-intel model=mbp11" accroding to this device list: … gic-cs4208

After that, I got consistent speaker output back at least (so far), however still no microphone input and headphones issues (unmuted, no volume in alsamixer).

Unfortunately, the same is the case for the "gpio0" "macmini" and "auto" models. With "mba6", microphone and headphones work, but only the internal tweeters get output, so the sound is extremely thin.

I guess I'm on my way now to just randomly try all models until I find something that works consistently...

Is there any way to read out which config other distributions use in their live systems? (Since some of those seem to work)

Last edited by DeusDeceptor (2023-09-21 12:14:29)


#2 2023-10-01 11:34:50

Registered: 2023-09-14
Posts: 4

Re: Macbook Pro 11,5 (2015): No internal speaker/mic

So, after meddling with this device for multiple weeks, I'll have to let it go.

I wasn't able to solve this issue. I thought it was a Plasma/Pulseaudio problem, but even the default config didn't work reliably. The speaker output and microphone were working one boot and gone after a reboot without changing anything in the configuration. Next boot something else happened to the sound devices, it's extremely erratic.

No common fix worked. Setting the default ALSA card or defining an intel-snd model worked for one boot, then it broke again the next start. Output levels and cards were always there, but no sound coming from the speakers (or headphones).

No other distro I've tried behaved like this, leading me to believe Arch expects a piece of config that I don't know of. It probably has to be some simple switch, but I can't spend any more time troubleshooting this one issue alone.

If somebody has the same problem and finds a fix, please let me know, I'd be interested, but I can't solve it.


Board footer

Powered by FluxBB