You are not logged in.

#1 2023-09-16 16:43:31

M440
Member
Registered: 2023-08-24
Posts: 28

Kscreen keep blocking xrandr settings, screen

hello,

first of all i would like to use Kscreen, because otherwise after suspend (and wake up) my screen is corrupted and I have to manually rerun a script setting my displays to make it correct. (i'm unable to make a systemd service for this because "display is not detected" or a  xrandr script in /usr/lib/systemd-sleep doesnt work, which would be a viable workaround)

xrandr --output DP-0 --mode 2560x1440_65 --pos 0x0 ... --output DP-4 --primary --mode 3440x1440 --rate 120 --pos 2560x0...

if i use Kscreen tho and I execute a script to manually turn off one of the displays (it draws 45 watt and is not always necessary)

xrandr --output DP-0 --off

therefore if i run the first script to turn the screen back on the Kscreen blocks it and waits for me to manually enable it in the system by using settings or widget,

How can i set Kscreen to not block the xrandr and autoenable screen?

I was able to set it in Xfce by setting "do nothing"

2023-09-16-17-06.png 2023-09-16-18-37.png

edit:

ok, it's

kscreen-doctor output.DP-0.enable output.DP-0.mode.549 output.DP-0.position.0,0 output.DP-4.enable output.DP-4.position.2560,0

edit:
sorry its not solved,

when i run it from the terminal its fine, but once i run it with xbindkeys it displays this silly dialog (above) even tho it has all the data


╰─>$ kscreen-doctor output.DP-0.enable output.DP-4.enable output.DP-0.mode.549 output.DP-0.position.0,0 output.DP-4.position.2560,0
Enabling output 540
Enabling output 715
kscreen.doctor: Taddaaa! Found mode "549" "2560x1440@65"
kscreen.doctor: Output 540 set mode "549"
kscreen.doctor: Output position QPoint(0,0)
kscreen.doctor: Set output position QPoint(0,0)
kscreen.doctor: Output position QPoint(2560,0)
kscreen.doctor: Set output position QPoint(2560,0)
kscreen.doctor: setop exec returned KScreen::Config(
KScreen::Output(540, "DP-0", connected enabled priority 2, pos: QPoint(0,0), res: QSize(2560, 1440), modeId: "549", scale: 1, clone: no, rotation: KScreen::Output::None, followPreferredMode: false)
KScreen::Output(715, "DP-4", connected enabled priority 1, pos: QPoint(2560,0), res: QSize(3440, 1440), modeId: "721", scale: 1, clone: no, rotation: KScreen::Output::None, followPreferredMode: false) )

edit:

after disabling iGPU in bios it does not display the dialogue

Last edited by M440 (2023-09-17 12:18:47)

Offline

Board footer

Powered by FluxBB