You are not logged in.

#1 2023-09-19 03:42:25

7ruedzn
Member
Registered: 2023-09-19
Posts: 1

Can't setup keyboard with hyprland

Hi everyone! I've been trying to use arch with hyprland for the past few days but can't quite figure it out how to setup the my keyboard correctly. I'm trying to use the brazilian keyboard and the abnt2 format, which includes ´, ~ and others. For my case, i can't use some like double points, underscore, double quotes, greater and less signs, question marks, etc. I noticed that every key that uses SHIFT + key is not correct. This is the output of my localectl

(Some signs like underscore i'm replacing with - just to output my config)

System Locale LANG=pt-BR.UTF-8
VC Keymap br-abnt2
X11 Layout br
X11 Model abnt2

This is my hyperland config

input
kb-layout = br
kb-variant = abnt2
kb-model = abnt2
kb-options =
kb-rules =

I have also created a 00-keyboard.conf at /etc/x11/xorg.conf.d with the following settings (replacing double quotes for single just to output my config)

Section 'inputClass'
    Identifier 'system-keyboard'
    MatchIsKeyboard 'on'
    Option 'XkbLayout' 'br'
    Option 'XkbModel' 'abnt2'
EndSection

Thanks for all the help, i'm really thankful!

Offline

#2 2023-09-19 07:23:34

seth
Member
Registered: 2012-09-03
Posts: 50,975

Re: Can't setup keyboard with hyprland

abnt2 isn't the model, but the variant.
localectl has a shit interface, https://wiki.archlinux.org/title/Xorg/K … _localectl pay attention to the "all preceding fields need to be specified, but the preceding fields can be skipped" part.
Also "InputClass" w/ an uppercase "I"

Not sure about the hyprland config.

Online

Board footer

Powered by FluxBB