You are not logged in.

#1 2023-10-27 15:33:05

fistrosan
Member
Registered: 2020-04-01
Posts: 171

pacman -Syu fails: kdesu5 vs kdesu

Trying to update my system:

:: Synchronizing package databases...
 core is up to date
 extra                                                                                                                          8.2 MiB  27.4 MiB/s 00:00 [##############################################################################################] 100%
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing kdesu5 (5.111.0-1) breaks dependency 'kdesu' required by polkit-dumb-agent-git

No idea how to proceed ... better ask the forum ...

Offline

#2 2023-10-27 15:42:50

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 12,150
Website

Re: pacman -Syu fails: kdesu5 vs kdesu

Do you need polkit-dumb-agent-git? If so, have you read the comments on that package's page?

Mod note: moving to AUR Issues

Aside: why do you still have the community repo? When did you last merge your pacnew files?

Last edited by WorMzy (2023-10-27 15:44:19)


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2023-10-27 18:21:24

fistrosan
Member
Registered: 2020-04-01
Posts: 171

Re: pacman -Syu fails: kdesu5 vs kdesu

WorMzy wrote:

Do you need polkit-dumb-agent-git? If so, have you read the comments on that package's page?

Mod note: moving to AUR Issues

Aside: why do you still have the community repo? When did you last merge your pacnew files?

Sorry, I did not even realize this was an AUR package. I must have installed it for some reason a while ago. Yes, I can see the comments. They do mention kdesu5. Since I have uninstalled now this polkit ... eventually the reason I installed it in the first place will become apparent.

Also, somehow I also missed the merging between [community] and [extra]. Thanks for pointing it out. I have now removed the repo and resynced.

Offline

Board footer

Powered by FluxBB