You are not logged in.

#1 2023-10-27 18:13:39

speerwerfer
Member
Registered: 2020-01-10
Posts: 23

[solved] Problems after Systemupdate

Hello,
I have a big problem and do not know what to do.
I just updated my system. The package manager offered me updates and I installed them all. After a reboot I now get this error message.
Clipboard.jpg
It is an Arch Linux with BTRFS and encrypted disk. Unfortunately I do not know exactly what the problem is now? Does the bootloader no longer find the SSD?

At the root prompt I can not enter anything. The keyboard is dead. I also tried to connect another keyboard, but that doesn't work either.

What is the best thing to do now?

Last edited by speerwerfer (2023-10-28 15:56:08)

Offline

#2 2023-10-27 18:34:23

speerwerfer
Member
Registered: 2020-01-10
Posts: 23

Re: [solved] Problems after Systemupdate

i start a live iso. the nvme0n1 is the internal ssd with my arch linux. i can mount the encrypted partition and when i enter the key i can read the data.

$ lsblk -f 
NAME                                          FSTYPE      FSVER            LABEL                 UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0                                         squashfs    4.0                                                                               0   100% /run/miso/sfs/livefs
loop1                                         squashfs    4.0                                                                               0   100% /run/miso/sfs/mhwdfs
loop2                                         squashfs    4.0                                                                               0   100% /run/miso/sfs/desktopfs
loop3                                         squashfs    4.0                                                                               0   100% /run/miso/sfs/rootfs
sda                                           iso9660     Joliet Extension MANJARO_CINNAMON_2137 2022-08-26-08-40-30-00                     0   100% /run/miso/bootmnt
├─sda1                                        iso9660     Joliet Extension MANJARO_CINNAMON_2137 2022-08-26-08-40-30-00                              
└─sda2                                        vfat        FAT12            MISO_EFI              2664-DC36                                           
sr0                                                                                                                                                  
nvme0n1                                                                                                                                              
├─nvme0n1p1                                   vfat        FAT32                                  1ED0-7693                             444,5M    13% /mnt/boot
└─nvme0n1p2                                   crypto_LUKS 2                                      23507e48-64d3-4d6b-b3b5-6c084481d2e6                
  └─luks-23507e48-64d3-4d6b-b3b5-6c084481d2e6 btrfs                                              8e52a5e6-a117-4d2c-b079-7329300c9679  335,2G    64% /run/media/manjaro/8e52a5e6-a117-4d2c-b079-7329300c9679


$ ls -al /run/media/manjaro/8e52a5e6-a117-4d2c-b079-7329300c9679/
total 16
drwxr-xr-x  1 root root     50  9. Feb 2023  .
drwxr-x---+ 3 root root     60 27. Okt 20:22 ..
drwxr-xr-x  1 root root    156 26. Sep 18:53 @
drwxr-xr-x  1 root root     24 12. Feb 2023  @home
drwxr-xr-x  1 root root    228 27. Okt 13:12 @log
drwxr-xr-x  1 root root 456916 27. Okt 19:39 @pkg
drwxr-xr-x  1 root root    504 27. Okt 19:39 @.snapshots

Last edited by speerwerfer (2023-10-27 19:09:31)

Offline

#3 2023-10-27 18:59:35

speerwerfer
Member
Registered: 2020-01-10
Posts: 23

Re: [solved] Problems after Systemupdate

$ blkid
/dev/nvme0n1p1: UUID="1ED0-7693" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="primary" PARTUUID="9d409b9d-0252-454d-9e52-9843c462497f"
/dev/nvme0n1p2: UUID="23507e48-64d3-4d6b-b3b5-6c084481d2e6" TYPE="crypto_LUKS" PARTLABEL="primary" PARTUUID="b515706f-fc03-498d-88aa-b64a05b4e100"
/dev/sda1: BLOCK_SIZE="2048" UUID="2022-08-26-08-40-30-00" LABEL="MANJARO_CINNAMON_2137" TYPE="iso9660"
/dev/sda2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="2664-DC36" BLOCK_SIZE="512" TYPE="vfat"
/dev/mapper/luks-23507e48-64d3-4d6b-b3b5-6c084481d2e6: UUID="8e52a5e6-a117-4d2c-b079-7329300c9679" UUID_SUB="9b56cfee-196d-4f0a-b0bb-75495651f18e" BLOCK_SIZE="4096" TYPE="btrfs"

/dev/sdaX are the Livesystem USB Stick

Offline

#4 2023-10-27 19:25:14

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [solved] Problems after Systemupdate

You might be running into https://bbs.archlinux.org/viewtopic.php?id=286293 or nt nvme modules aren't in the initrmfs.

Offline

#5 2023-10-27 19:59:06

speerwerfer
Member
Registered: 2020-01-10
Posts: 23

Re: [solved] Problems after Systemupdate

OK, can you please help me a little - this is the config for the initramfs

$ cat /etc/mkinitcpio.conf
MODULES=(btrfs)
BINARIES=(/usr/bin/btrfs)
FILES=()
HOOKS=(base udev autodetect keyboard keymap modconf block encrypt filesystems fsck)

its a system with systemd-boot (no grub installed)

Last edited by speerwerfer (2023-10-27 20:12:58)

Offline

#6 2023-10-27 20:04:35

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [solved] Problems after Systemupdate

Well, you're using the udev hook, so the linke thread is relevant.
https://wiki.archlinux.org/title/Mkinit … mmon_hooks
https://wiki.archlinux.org/title/Dm-cry … mkinitcpio

Reg. the nvme modules

lsinitcpio /mnt/boot/initramfs-linux.img | grep nvme # substitute the path to the mounted boot partition

Offline

#7 2023-10-27 20:22:12

speerwerfer
Member
Registered: 2020-01-10
Posts: 23

Re: [solved] Problems after Systemupdate

OK, I will read the thread and try to understand :-)

But the following command gives no output. The string nvme is not found.

$ lsinitcpio /mnt/boot/initramfs-linux.img | grep nvme
$

for info: its a system with systemd-boot (no grub installed)

$ cat /mnt/boot/loader/entries/2023-02-09_16-41-07_linux.conf 
# Created by: archinstall
# Created on: 2023-02-09_16-41-07
title Arch Linux (linux)
linux /vmlinuz-linux
initrd /amd-ucode.img
initrd /initramfs-linux.img
options cryptdevice=PARTUUID=b515706f-fc03-498d-88aa-b64a05b4e100:luksdev root=/dev/mapper/luksdev zswap.enabled=0 rootflags=subvol=@ rw intel_pstate=no_hwp rootfstype=btrfs 

Last edited by speerwerfer (2023-10-27 20:25:20)

Offline

#8 2023-10-27 20:31:38

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [solved] Problems after Systemupdate

Sanity check:

stat /mnt/boot/initramfs-linux.img
lsinitcpio /mnt/boot/initramfs-linux.img | wc -l
Because seth wrote:

substitute the path to the mounted boot partition

Offline

#9 2023-10-27 20:35:36

speerwerfer
Member
Registered: 2020-01-10
Posts: 23

Re: [solved] Problems after Systemupdate

$ stat /mnt/boot/initramfs-linux.img
  File: /mnt/boot/initramfs-linux.img
  Size: 14911779  	Blocks: 29128      IO Block: 4096   regular file
Device: 259,1	Inode: 11          Links: 1
Access: (0755/-rwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2023-10-27 02:00:00.000000000 +0200
Modify: 2023-10-27 19:39:52.000000000 +0200
Change: 2023-10-27 19:39:52.750000000 +0200
 Birth: -

$ lsinitcpio /mnt/boot/initramfs-linux.img | wc -l
547

Offline

#10 2023-10-27 20:41:13

seth
Member
Registered: 2012-09-03
Posts: 53,432

Re: [solved] Problems after Systemupdate

Add "nvme" to the modules and regenerate the initramfs.

Offline

#11 2023-10-27 20:44:25

speerwerfer
Member
Registered: 2020-01-10
Posts: 23

Re: [solved] Problems after Systemupdate

you mean:

MODULES=(btrfs nvme)
BINARIES=(/usr/bin/btrfs)
FILES=()
HOOKS=(base systemd autodetect keyboard sd-vconsole modconf block sd-encrypt filesystems fsck)

It is already late here. I'll continue tomorrow before I make a mistake now. Thanks so far

EDIT: wrong config definition

Last edited by speerwerfer (2023-10-27 20:52:14)

Offline

#12 2023-10-28 15:55:48

speerwerfer
Member
Registered: 2020-01-10
Posts: 23

Re: [solved] Problems after Systemupdate

Hooray, I am back in my system! Thanks a lot!

For those who stop by here later, here are the two changes I had to make.

In my /etc/mkinitcpio.conf from

MODULES=(btrfs)
BINARIES=(/usr/bin/btrfs)
FILES=()
HOOKS=(base udev autodetect keyboard keymap modconf block encrypt filesystems fsck)

to

MODULES=(nvme btrfs)
BINARIES=(/usr/bin/btrfs)
FILES=()
HOOKS=(base systemd autodetect keyboard sd-vconsole modconf block sd-encrypt filesystems fsck)

and then run

mkinitcpio -P

And then in /boot/loader/entries/linux.conf from

title Arch Linux (linux)
linux /vmlinuz-linux
initrd /amd-ucode.img
initrd /initramfs-linux.img
options cryptdevice=PARTUUID=b515706f-fc03-498d-88aa-b64a05b4e100:luksdev root=/dev/mapper/luksdev zswap.enabled=0 rootflags=subvol=@ rw intel_pstate=no_hwp rootfstype=btrfs

to

title Arch Linux (linux)
linux /vmlinuz-linux
initrd /amd-ucode.img
initrd /initramfs-linux.img
options rd.luks.name=23507e48-64d3-4d6b-b3b5-6c084481d2e6=luksdev root=/dev/mapper/luksdev zswap.enabled=0 rootflags=subvol=@ rw intel_pstate=no_hwp rootfstype=btrfs

Offline

Board footer

Powered by FluxBB