You are not logged in.

#1 2023-10-31 21:50:35

xelq9fgf4p
Member
Registered: 2021-03-26
Posts: 3

[SOLVED] Unfamiliar prompt when trying to format luks encrypted par...

Hello,

I am doing a fresh installation of Arch Linux with a luks encrypted root partition, which I have done many times before. However, it's been a while and this time I am getting a message I haven't seen before.

I have booted into a live usb Arch iso environment and created the encrypted partition using:

 cryptsetup -y -v luksFormat /dev/nvme0n1p6 

Then I opened it using:

 cryptsetup open /dev/nvme0n1p6 cryptroot 

Now I want to format /dev/mapper/cryptroot prior to mounting it using:

 mkfs.ext4 /dev/mapper/cryptroot 

When I run the previous command, I get the following prompt: /dev/mapper/cryptroot contains 'OpenPGP Secret Key' data. Proceed anyway?

I don't recall getting this prompt in the past and I'm not sure exactly it means. Will formatting overwrite encryption key data? Or is it basically just telling me this is an encrypted partition? Obviously, I will need a filesystem on the partition for it to be usable.

I tried searching but couldn't find a post regarding this scenario specifically.

Last edited by xelq9fgf4p (2023-11-01 16:50:42)

Offline

#2 2023-11-01 08:33:12

seth
Member
Registered: 2012-09-03
Posts: 54,214

Re: [SOLVED] Unfamiliar prompt when trying to format luks encrypted par...

Elsewhere only shows up in https://miloserdov.org/?p=7267#5
https://git.kernel.org/pub/scm/fs/ext2/ … ble.c#n259

file /dev/mapper/cryptroot

will likely tell you that "this looks like an OpenPGP Secret Key to me" and you can suppress that magic test w/ the environment variable in the link.

Offline

Board footer

Powered by FluxBB