You are not logged in.

#1 2023-11-05 20:04:27

Invalid_Profile
Member
Registered: 2023-11-05
Posts: 5

[SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

A few days ago, I attempted to update my packages using yay and ran into a bug (https://bugs.archlinux.org/task/80148). Realizing it was a repo issue, I decided to wait for a fix. In the meantime, I instructed pacman to ignore the nvidia-utils-535 package and proceeded to upgrade the rest, which went smoothly.
Fast forward a bit and the bug with the repo seems to have been fixed, but now when I upgrade the package (nvidia-utils-535 -> nvidia-utils-545), my system seems to act like I don't have any graphics drivers installed and breaks my desktop environment. I figured out how to roll back the package from pacman's cache to fix the issue but:

A) it's kind of annoying to tell pacman to ignore the package every time I upgrade
B) I'm afraid keeping this package held back will cause issues further down the line.

I tried switching from "nvidia" to "nvidia-dkms" but I'm still having the same issue with "nvidia-utils"

First forum post here, so go easy on me. I'm fairly new to Arch after using Mint for the past 2 years, but am loving Arch and want to stick with it. Please let me know if you need any more details from me or if I'm being a dumb dumb with something obvious.

Thanks.

Output of pacman -Qi nvidia-utils:

Name            : nvidia-utils
Version         : 535.113.01-2
Description     : NVIDIA drivers utilities
Architecture    : x86_64
URL             : [url]http://www.nvidia.com/[/url]
Licenses        : custom
Groups          : None
Provides        : vulkan-driver  opengl-driver  nvidia-libgl
Depends On      : libglvnd  egl-wayland
Optional Deps   : nvidia-settings: configuration tool [installed]
                  xorg-server: Xorg support [installed]
                  xorg-server-devel: nvidia-xconfig
                  opencl-nvidia: OpenCL support [installed]
Required By     : cuda  lib32-nvidia-utils  libglvnd  nvidia-settings  python-py3nvml  steam
Optional For    : ffmpeg  ffmpeg4.4  libvdpau  vulkan-icd-loader
Conflicts With  : nvidia-libgl
Replaces        : nvidia-libgl
Installed Size  : 673.39 MiB
Packager        : Sven-Hendrik Haase <svenstaro@archlinux.org>
Build Date      : Sun 24 Sep 2023 05:23:11 PM CDT
Install Date    : Sun 05 Nov 2023 01:24:50 PM CST
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature

System Info:

OS: Arch Linux x86_64 
Kernel: 6.5.9-arch2-1 
Uptime: 31 mins 
Packages: 943 (pacman) 
Shell: bash 5.2.15 
Resolution: 2048x1152, 2560x1440 
DE: Xfce 4.18 
WM: Xfwm4 
WM Theme: Default 
Theme: Orchis-Purple-Dark [GTK2/3] 
Icons: Colorful-Dark-Icons [GTK2/3] 
Terminal: guake 
CPU: AMD Ryzen 7 3800X (16) @ 4.200GHz 
GPU: NVIDIA GeForce RTX 3080 
Memory: 3426MiB / 31999MiB

Last edited by Invalid_Profile (2023-11-07 00:47:16)

Offline

#2 2023-11-05 20:40:47

seth
Member
Registered: 2012-09-03
Posts: 54,446

Re: [SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

https://bugs.archlinux.org/task/80148 is resolved and has been an issue w/ the nvidia package only, so it's not clear what your previous and/or ongoing issue is.
Update the system, boot the multi-user.target (2nd link below) and then please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Offline

#3 2023-11-05 21:40:23

yochananmarqos
Member
Registered: 2020-02-05
Posts: 205

Re: [SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

As @seth said, the issue is already resolved. Remove any packages you added to IgnorePkg, make sure your mirrors are up to date, perform a full update and reboot.

Offline

#4 2023-11-05 22:02:47

Invalid_Profile
Member
Registered: 2023-11-05
Posts: 5

Re: [SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

seth wrote:

https://bugs.archlinux.org/task/80148 is resolved and has been an issue w/ the nvidia package only, so it's not clear what your previous and/or ongoing issue is.
Update the system, boot the multi-user.target (2nd link below) and then please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Will do when I get the chance and get back to you.

Offline

#5 2023-11-05 22:12:17

Invalid_Profile
Member
Registered: 2023-11-05
Posts: 5

Re: [SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

yochananmarqos wrote:

As @seth said, the issue is already resolved. Remove any packages you added to IgnorePkg, make sure your mirrors are up to date, perform a full update and reboot.

That's the problem, when I do a full update, my system breaks. I haven't added anything to IgnorePkg. My issue isn't exactly the bug linked before; I was providing some context since I figured it may be related. The bug was that pacman wouldn't install the update because of dependency issues. That has been fixed and I can install the package now. The problem I'm having now, is my DE stops working when I upgrade the package.

Offline

#6 2023-11-05 23:47:49

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,798

Re: [SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

Do you have the nvidia module in the initramfs, either via the modules array or via the kms hook? If so, did you rebuild the initramfs so it gets the new module?

Offline

#7 2023-11-06 05:14:55

wyrmlet
Member
Registered: 2023-11-05
Posts: 3

Re: [SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

I completely missed the repo problem, but upon updating the system the most recent nvidia-dkms drivers broke as well, with no GPU detected from vulkaninfo and my WM crashing. It seems like installing the latest package does not regenerate initramfs for some reason, and doing it manually with

sudo mkinitcpio -P

fixed the issue for me.

Last edited by wyrmlet (2023-11-06 05:15:21)

Offline

#8 2023-11-06 08:20:07

seth
Member
Registered: 2012-09-03
Posts: 54,446

Re: [SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

It seems like installing the latest package does not regenerate initramfs for some reason, and doing it manually with

https://wiki.archlinux.org/title/NVIDIA#pacman_hook

Offline

#9 2023-11-07 00:30:23

Invalid_Profile
Member
Registered: 2023-11-05
Posts: 5

Re: [SOLVED] Nvidia Drivers Break When Upgrading nvidia-utils

wyrmlet wrote:

I completely missed the repo problem, but upon updating the system the most recent nvidia-dkms drivers broke as well, with no GPU detected from vulkaninfo and my WM crashing. It seems like installing the latest package does not regenerate initramfs for some reason, and doing it manually with

sudo mkinitcpio -P

fixed the issue for me.


Ah man, that fixed it for me as well! When I installed my drivers I used this guide https://github.com/korvahannu/arch-nvid … tion-guide but I didn't do the hooks section because I figured I didn't need to. I thought that was something for people using older cards. I didn't know what a pacman hook was until now. Newbie error on my end!

Last edited by Invalid_Profile (2023-11-07 00:37:20)

Offline

Board footer

Powered by FluxBB