You are not logged in.

#1 2023-11-09 14:44:51

Lostless
Member
Registered: 2023-11-09
Posts: 5

VA-API does not work.

When I open a video from VLC, the CPU is used.

vainfo
Trying display: wayland
Trying display: x11
libva error: vaGetDriverNames() failed with unknown libva error
vainfo: VA-API version: 1.20 (libva 2.20.0)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.4
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD

Offline

#2 2023-11-09 15:32:15

seth
Member
Registered: 2012-09-03
Posts: 52,621

Offline

#3 2023-11-09 16:12:48

Lostless
Member
Registered: 2023-11-09
Posts: 5

Re: VA-API does not work.

lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation G96C [GeForce 9400 GT] (rev a1)
03:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)

Offline

#4 2023-11-09 16:20:26

seth
Member
Registered: 2012-09-03
Posts: 52,621

Re: VA-API does not work.

You're probably using nouveau and I highly doubt that that chip had any video decoding capacity

Offline

#5 2023-11-09 17:54:29

Lostless
Member
Registered: 2023-11-09
Posts: 5

Re: VA-API does not work.

I use Nvidia closed source drivers.

Offline

#6 2023-11-09 18:05:59

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,664

Re: VA-API does not work.

If you installed some really old drivers from the AUR, that's possible; but what codec are you trying to use? The output you posted shows the very limited codecs available to decode.

Online

#7 2023-11-09 19:26:07

Lostless
Member
Registered: 2023-11-09
Posts: 5

Re: VA-API does not work.

H.264 MPEG-4 avc1

Offline

#8 2023-11-09 20:02:58

seth
Member
Registered: 2012-09-03
Posts: 52,621

Re: VA-API does not work.

This changes little about the situation, you still need to configure the proper driver.
Stop the one-line answers, post your xorg log and wrt. vaapi, explain what VAAPI drivers you installed and how you configured them.

Also, in general, you really don't want to use vaapi and prefer vdpau w/ nvidia.
The GPU however is the 2nd PV generation and should™ be able to decode most h264 profiles.

Offline

#9 2023-11-11 11:19:18

Lostless
Member
Registered: 2023-11-09
Posts: 5

Re: VA-API does not work.

I apologise for my late reply. I want to use VA-API because VDPAU is not available in Chrome. I set the LIBVA_DRIVER_NAME environment variable to vdpau. I installed lib32-libva-vdpau-driver, libva-vdpau-driver-chromium packages. What is wrt?
https://www.mediafire.com/file/a5ilwo7v … 0.log/file

Offline

#10 2023-11-11 12:35:44

Lone_Wolf
Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,060

Re: VA-API does not work.

wrt = with respect to

[   262.316] Current Operating System: Linux bilgisayar 6.6.1-1-cachyos-sched-ext #1 SMP PREEMPT_DYNAMIC Thu, 09 Nov 2023 03:27:35 +0000 x86_64
[   262.316] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux-cachyos-sched-ext root=UUID=bb2496fb-9bf4-4784-a20b-6b8bb38cfec8 rw loglevel=3 quiet mitigations=off nmi_watchdog=0 module_blacklist=iTCO_wdt ibt=off nvidia_drm.modeset=1 clearcpuid=514 zswap.enabled=0 vt.global_cursor_default=0

CachyOS is not supported here.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#11 2023-11-11 12:38:33

seth
Member
Registered: 2012-09-03
Posts: 52,621

Offline

Board footer

Powered by FluxBB