You are not logged in.

#1 2007-01-20 20:11:50

bored2k
Member
Registered: 2006-01-14
Posts: 39

Playback: MP4/M4A files in Gstreamer **Solved**

I've search through the forums and installed virtually every single package that's been referred to fix this playback issue to no avail. Anything special I need to know/do/install? smile

Offline

#2 2007-01-20 21:43:17

picpak
Member
Registered: 2006-12-02
Posts: 89

Re: Playback: MP4/M4A files in Gstreamer **Solved**

bored2k, I didn't know you use Arch smile

Apparently the program you want is gstreamer-quicktime, has anyone made a PKGBUILD for it?


Regards,
Picpak

Offline

#3 2007-01-20 23:15:58

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: Playback: MP4/M4A files in Gstreamer **Solved**

gstreamer0.10-faad (hopefully) will work.

Offline

#4 2007-01-21 03:12:11

bored2k
Member
Registered: 2006-01-14
Posts: 39

Re: Playback: MP4/M4A files in Gstreamer **Solved**

skottish wrote:

gstreamer0.10-faad (hopefully) will work.

# pacman -S gstreamer0.10-faad
:: gstreamer0.10-faad-0.10.4-1: is up to date.  Upgrade anyway? [Y/n] n

:-/

Offline

#5 2007-01-21 17:26:58

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: Playback: MP4/M4A files in Gstreamer **Solved**

Try installing the 'codecs' package if you haven't already.

Offline

#6 2007-01-21 23:16:47

bored2k
Member
Registered: 2006-01-14
Posts: 39

Re: Playback: MP4/M4A files in Gstreamer **Solved**

skottish wrote:

Try installing the 'codecs' package if you haven't already.

Already installed. =/

/me smells a Windows boot + M4A Conversion...

Offline

#7 2007-01-22 03:32:09

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: Playback: MP4/M4A files in Gstreamer **Solved**

You need to install openquicktime, then rebuild gst-plugins with the --enable-quicktime flag.

http://foo-projects.org/pipermail/lunar … 37853.html

Offline

#8 2007-01-22 06:44:13

bored2k
Member
Registered: 2006-01-14
Posts: 39

Re: Playback: MP4/M4A files in Gstreamer **Solved**

skottish wrote:

You need to install openquicktime, then rebuild gst-plugins with the --enable-quicktime flag.

http://foo-projects.org/pipermail/lunar … 37853.html

Eeck, sloppy fix :-s. Is there a particular reason why there's not even a package for openquicktime, nor a correct m4a-enabled builds? I find it hard to believe that everyone wanting m4a playback has to do this...

Offline

#9 2007-01-22 06:49:30

bored2k
Member
Registered: 2006-01-14
Posts: 39

Re: Playback: MP4/M4A files in Gstreamer **Solved**

The latest gstreamer0.10-faad updated solved it ! :-D

Offline

Board footer

Powered by FluxBB