You are not logged in.

#1 2023-11-11 18:20:21

Registered: 2023-11-11
Posts: 2

[SOLVED] makepkg: ==> ERROR: A failure occurred in build().

I just installed managed to install arch linux on my laptop, and everything works. Im using lxqt as the desktop enviroment and i can connect to my wifi using iwctl and iwd.

I tried to install nm-tray widget so i can connect to wifi using the lxqt panel. I tried doing it the normal way with makepkg, then i tried pamac, but it couldnt install. Other packages like pamac and minecraft-launcher and some dependencies from AUR built succesfully, but i keep getting this error when trying to build nm-tray

[mario0fan@archymarchy nm-tray]$ makepkg
==> Making package: nm-tray 0.5.0-2 (Sat Nov 11 18:12:55 2023)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found nm-tray-0.5.0.tar.gz
==> Validating source files with sha256sums...
    nm-tray-0.5.0.tar.gz ... Passed
==> Extracting sources...
  -> Extracting nm-tray-0.5.0.tar.gz with bsdtar
bsdtar: Failed to set default locale
==> Removing existing $pkgdir/ directory...
==> Starting build()...
CMake Warning (dev) at CMakeLists.txt:1 (project):
  cmake_minimum_required() should be called prior to this top-level project()                                       
  call.  Please see the cmake-commands(7) manual for usage documentation of                                         
  both commands.                                          
This warning is for project developers.  Use -Wno-dev to suppress it.                                               
CMake Error: CMake was unable to find a build program corresponding to "Unix Makefiles".  CMAKE_MAKE_PROGRAM is not set.  You probably need to select a different build tool.
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().

I can use iwctl to connect, but i really wanna install nm-tray.
Thank you if anybody helps big_smile

Last edited by mario0fan (2023-11-11 18:37:46)


#2 2023-11-11 18:30:41

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,425

Re: [SOLVED] makepkg: ==> ERROR: A failure occurred in build().

Builds fine in a clean chroot. I'd hazard a guess that you haven't installed the prerequisites for building AUR packages. … requisites

Mod note: Moving to AUR Issues

Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


#3 2023-11-11 18:37:32

Registered: 2023-11-11
Posts: 2

Re: [SOLVED] makepkg: ==> ERROR: A failure occurred in build().

Thank you! It works now! Im new to arch linux, sorry for making a mistake like that :)page.codeberg.JakobDev.jdMinecraftLauncher


Board footer

Powered by FluxBB