You are not logged in.

#1 2023-12-03 11:13:39

dxrkness
Member
From: Ukraine, Kharkiv
Registered: 2023-12-03
Posts: 4

AMDGPU Failed to send message with constant freezes

Kernel: Linux 6.6.3-arch1-1 x86_64 (tried downgrading to earlier version, specifically 6.5.5, but it's no good. freezes still were there)
GPU: AMD Vega 11 (Ryzen 5 3400G)
Mesa: mesa-git 24.0.0_devel.181311.8cfae774395.d41d8cd-1 (updated to upstream version, but on the stable the things are the same)
DE: Gnome on Wayland
Displays: 1920x1080@75hz, 1920x1080@60hz

In short, once an hour/two/three, my computer freezes every five seconds for at least five seconds (giving me almost second between freezes). This freezes persist for a minute or so total
Here is the usual output of dmesg:

[ 2057.989502] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2062.712966] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2067.303996] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2072.044987] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2077.143229] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2081.802027] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2086.655186] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2091.182774] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 2a.
[ 2095.958797] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 2b.
[ 2100.686635] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 2a.
[ 2105.156367] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 8.
[ 2109.804510] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2114.521261] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 2a.
[ 2119.025779] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 8.
[ 2123.740642] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 7.
[ 2129.232129] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 2a.
[ 2133.672030] amdgpu 0000:06:00.0: amdgpu: Failed to send Message 2b.

Both nvtop and amdgpu_top show normal usage (amdgpu_top shows 0% usage in the moment of freezes), lm-sensors show usual GPU temperature (usually, under 40 deg. C).
There are no connected messages before or after that (the message before is 900 seconds earlier).
From what I would find, the messages are connected with some SMU features. Tbh, I don't know what is this, since this issue hasn't appeared before.
I wouldn't suspect any updates, because I didn't pacman -Syu that day, actually did it after it started lagging.

It seems like it started out of nowhere, I was just doing my usual work (coding, browsing internet etc.), and it started freezing.
The issue persists for several days, I've tried everything I could find, including disabling AMD fTPM in bios, but it's no good.

Last edited by dxrkness (2023-12-03 11:17:15)

Offline

#2 2023-12-03 13:53:31

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,628
Website

Re: AMDGPU Failed to send message with constant freezes

Try disabling the dynamic power management for the iGPU: https://wiki.archlinux.org/title/ATI#Dy … management

Offline

#3 2023-12-03 19:12:00

dxrkness
Member
From: Ukraine, Kharkiv
Registered: 2023-12-03
Posts: 4

Re: AMDGPU Failed to send message with constant freezes

❯ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=* rw loglevel=3 radeon.dpm=0 quiet

Freeze spikes still occur though.

One thing I noticed is that these freezes happen around 2000 seconds since computer start (maybe it's just a coincidence, but a little fun fact to point out)

Offline

#4 2023-12-03 19:17:34

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,628
Website

Re: AMDGPU Failed to send message with constant freezes

Not sure about this. Perhaps check the RAM health. #stabinthedark

Offline

#5 2023-12-04 09:22:56

dxrkness
Member
From: Ukraine, Kharkiv
Registered: 2023-12-03
Posts: 4

Re: AMDGPU Failed to send message with constant freezes

Memtest86+ is giving me 0 errors. Not sure what to do D:

Offline

#6 2023-12-04 16:17:52

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,628
Website

Re: AMDGPU Failed to send message with constant freezes

Perhaps post the a full journal log from an instance of the freeze. I found https://bugzilla.kernel.org/show_bug.cgi?id=204609 but it doesn't look quite the same as your issue. Did you see that thread?

Also: Слава Україні!

Offline

#7 2023-12-12 09:41:19

dxrkness
Member
From: Ukraine, Kharkiv
Registered: 2023-12-03
Posts: 4

Re: AMDGPU Failed to send message with constant freezes

Issue seems to have gone by itself! Great appreciation for your help!)


Head_on_a_Stick wrote:

Also: Слава Україні!

P. S. Героям слава:)

Offline

Board footer

Powered by FluxBB