You are not logged in.

#1 2024-01-12 22:49:02

Registered: 2022-01-14
Posts: 46

[SOLVED] Stuck at "A start job is running..."

I'm trying to set up a LVM-on-LUKS type system. Actually I already had that setup successfully running with GRUB but decided to switch to systemd-boot. After doing "bootctl install" I wrote this entry, with the "options" line just the copied kernel parameters from the GRUB config.

title   Arch Linux
linux   /vmlinuz-linux
initrd  /initramfs-linux.img
options root=/dev/vg-arch2/root"

From my understanding the name after the UUID (=x) doesn't matter. The system boots up like this:

Expecting device /dev/disk/by-uuid/453...
Expecting device /dev/vg-arch2/root
Expecting device /dev/vg-arch2/root
...blah blah ...(I'm typing this from cell phone photos taken from the screen)
Please enter passphrase for disk .... (vg-arch2)
Finished Cryptography Setup for vg-arch2
Reached target Local Encrypted Volumes
Reached target System Initialization
Reached target Basic System
Found device /dev/vg-arch2/root
A start job is running for /dev/vg-arch2/root
A start job is running for /dev/vg-arch2/root
A start job is running for /dev/vg-arch2/root
A start job is running for /dev/vg-arch2/root
(this goes on for 90 seconds)
Timed out waiting for device /dev/vg-arch2/root
(more stuff)
Started Emergency shell
Reached target Emergency Mode
You are in emergency mode. After logging in ...

Cannot open access to console, the root account is locked.

And that's it. Note that the line "Expecting device /dev/vg-arch2/root" appears twice in at the very top of the console output. Does that mean anything?

I didn't change the initrd or the kernel after switching to systemd-boot from the working GRUB installation.

Here's the content of my /boot partition (leaving out Windows stuff):


Last edited by musbur (2024-01-14 18:49:15)


#2 2024-01-14 18:48:48

Registered: 2022-01-14
Posts: 46

Re: [SOLVED] Stuck at "A start job is running..."

It took me days to realize that the problem was caused by a single double-quote sign (") after the correct UUID (leftover from a sloppy commandline-copy-and-paste): The device is detected when it comes up, the password prompt appears, the LUKS device is unlocked, and then initramfs is stuck in a "A start job is running for /dev/...." loop. Try it sometimes. It's fun.


Board footer

Powered by FluxBB