You are not logged in.

#1 2024-01-15 16:23:54

lenhuppe
Member
From: New Hampshire USA
Registered: 2018-12-10
Posts: 273
Website

SOLVED XZ ver 5.4.5-1 issue with Archiso 74-1

After upgrading XZ to version 5.4.5-1 my archiso images are noticeably larger. They were 790mb and now they are 925mb.

When running mkarchiso I get the following error message, but the images have been booting ok from USB:

==> Creating xz-compressed initcpio image: '/boot/initramfs-linux-zen.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
error: command failed to execute correctly

I am not a programmer so I don't know how minor or innocuous the issue is.

I found the following entry in the /usr/share/archiso/configs/releng/profiledef.sh file:

airootfs_image_tool_options=('-comp' 'xz' '-Xbcj' 'x86' '-b' '1M' '-Xdict-size' '1M')

Can this entry be modified to remedy the above-mentioned issue?

Last edited by lenhuppe (2024-01-15 18:02:06)


Why do we drive on the parkway and then park in the driveway?

Offline

#2 2024-01-15 16:25:02

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,798

Re: SOLVED XZ ver 5.4.5-1 issue with Archiso 74-1

More likely it's the kernel update that did it. See https://bbs.archlinux.org/viewtopic.php?id=291900

Online

#3 2024-01-15 18:01:33

lenhuppe
Member
From: New Hampshire USA
Registered: 2018-12-10
Posts: 273
Website

Re: SOLVED XZ ver 5.4.5-1 issue with Archiso 74-1

My use case does not require me to be on the bleeding edge so I tried switching from the linux-zen kernel to linux-lts.

My ISO images are smaller, and I am no longer getting the "boot partition full" errors I was seeing with the 6.7-zen kernel.


Why do we drive on the parkway and then park in the driveway?

Offline

Board footer

Powered by FluxBB