You are not logged in.

#1 2024-01-30 02:27:51

genericity
Member
Registered: 2014-09-20
Posts: 26

Plasma screenlocker errors in journal

In Plasma 6.0 RC1, the lockscreen produces the following priority-3 errors in the journal, when "fprint" and "pam_pkcs11" are not installed:

kscreenlocker_greet[9492]: PAM unable to dlopen(/usr/lib/security/pam_fprintd.so)
kscreenlocker_greet[9492]: PAM adding faulty module: /usr/lib/security/pam_fprintd.so
kscreenlocker_greet[9492]: PAM unable to dlopen(/usr/lib/security/pam_pkcs11.so)
kscreenlocker_greet[9492]: PAM adding faulty module: /usr/lib/security/pam_pkcs11.so

It can be fixed by changing this line in "/etc/pam.d/kde-fingerprint":

auth       required                    pam_fprintd.so

to:

-auth       required                    pam_fprintd.so

(And do similar change to "/etc/pam.d/kde-smartcard")

PAM returns "PAM_MODULE_UNKNOWN" in this case, and then "kscreenlocker" will silently ignore these auth methods.

Sorry, should have created a pull request. But can't register to gitlab at the moment.

Last edited by genericity (2024-01-30 02:29:27)

Offline

Board footer

Powered by FluxBB