You are not logged in.

#1 2024-02-11 05:19:45

Registered: 2022-09-18
Posts: 11

[Solved] Installation is broken; freezing with unknown errors

My Arch installation seems to be incredibly broken, I can't even get to the shell anymore. It was working no problems, but then I decided to reinstall everything after I'd gotten my build perfect and that's when the problems started. I've tried 5 different bootable USBs now and there's no difference, even redownloading the iso didn't work. There's three different ways that the installation is breaking, and I have absolutely no idea both why they're occurring or how to fix them. I need to use this as my workstation pretty imminently so if you could please help as much as you can I'd really appreciate it thank you so much <3

1) Freezes at Triggering uevents...
This was happening about 30% of the time, however now 100% of the time when booting from the UEFI part of the USB. Its as simple as the title suggests, the cursor stops flashing and the system freezes at Triggering uevents... Only way to escape is to hold the power button.

2) Gets past Triggering uevents..., but displays whole pages worth of unknown messages before the shell appears. Here is some of whats happening
The whole screen fills with messages always starting with [        32.334371], the 32 is always the same but the other number increases in size each message, here's a portion of it

[      32.331822] CPU: 6 PID: 1 Comm: systemd Not tainted 6.7.2-arch1-2 #1 (then a whole bunch of letters and numbers)
[      32.3383041] ? die_addr+0x36/0x90
[      32.338746] ? exc_general_protection+0x1c5/0x430
[      32.339252] ? asm_exc_general_protection+0x26/0x30
[      32.339747] ? push_jmp_history+0x5c/0xa0

3) Gets all the way until installing the base packages using pacstrap and right at the end of installing them I get messages similar to 2) but with different numbers at the front, here are some of the ones unique to 3)

[ 2111.566467] audit: type=1130 audit(1707563680.458:143): pid=1 uid=1 auid=4294967295 ses=4294967295 ms(... this trails off the photo I took)
/usr/bin/pacstrap: line 465: 1171 Segmentation fault              (core dumped) $pid_unshare pacman -r "$newroo(... trails off)

Then a couple more audit messages before displaying very similar messages to in 2)

In both 2) and 3) there's something to do with a Call Trace

I tried using an EndeavourOS bootable with zero errors at all, so it seems that it's not my desktop that's the problem.

Last edited by carryingweight (2024-02-11 07:47:02)


#2 2024-02-11 07:48:00

Registered: 2022-09-18
Posts: 11

Re: [Solved] Installation is broken; freezing with unknown errors

My bad, this solved it all straight away


Board footer

Powered by FluxBB