You are not logged in.

#1 2024-02-11 19:09:08

jfab
Member
Registered: 2024-02-11
Posts: 9

Cpu usage over 200% on fresh installation of arch

Yesterday I updated my system with pacman -Syu to linux l 6.7.4 and the computer became very slow. Powertop was showing some acpi interrumpt process using a lot of CPU (like here https://ibb.co/Ct2X7s7, almost 200% cpu usage with almost no processes running) and journalctl had a lot of ACPI errors.

I tried to search everywhere for this error and got tired. I wiped my computer and re installed from scratch (with the arch install script). To my surprise the issue persists on a fresh install of arch. I am now running Manjaro and the issue is gone.

This issue is wm/de dependent as I tried to install arch multiple ways with different de/wm and it didn't work either. This issue was even present in the tty and without installing too much packages after a fresh install.

I tried adding the kernel parameters "pci=nommconf" and "acpi=off" with no success, and in that case my computer didn't even boot. I also tried booting with linux-lts with no luck.

My laptop is a VivoBook_ASUSLaptop E406NA_L406NA 1.0.

Images of powertop, neofetch and journalctl errros are here:

Journalctl:
https://ibb.co/5B9NnB4

Powertop:
https://ibb.co/S7k5Psc

Neofetch (I'm in Manjaro now):
https://ibb.co/MZLB9D4

Last edited by jfab (2024-02-11 19:11:46)

Offline

#2 2024-02-11 20:55:10

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Cpu usage over 200% on fresh installation of arch

Don't post photos of the text on your monitor, post the text.

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Offline

#3 2024-02-12 00:58:51

jfab
Member
Registered: 2024-02-11
Posts: 9

Re: Cpu usage over 200% on fresh installation of arch

As I said I installed Manjaro since the computer with arch is VERY slow. Even running commands on the terminal is slow, that is why I didn't upload the text.

Offline

#4 2024-02-12 08:57:19

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Cpu usage over 200% on fresh installation of arch

Then this here is completely pointless - it's impossible to give you meaningful advice based solely on https://i.ibb.co/yWRwYWP/journalctl.webp
You could test the LTS kernel (because manjaro likely defaults to that) but that's just a guess and no matter what: you'll have to produce meaningful data from the problematic system.

Offline

#5 2024-02-13 14:32:47

jfab
Member
Registered: 2024-02-11
Posts: 9

Re: Cpu usage over 200% on fresh installation of arch

Ok, I reinstalled arch and got the same error. Here is journalctl -b: https://0x0.st/HdwG.txt

Powertop still outputs 200%+ cpu usage. Most intense processes are systemd-journal and acpi

Last edited by jfab (2024-02-13 14:33:44)

Offline

#6 2024-02-13 14:47:56

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Cpu usage over 200% on fresh installation of arch

Add

pci=noaer

to the https://wiki.archlinux.org/title/Kernel_parameters
The journal actually isn't complete and barely contains anything but the insane amount of ACPI error

journald sucks at burst handling, that's what's most likely driving your CPU - we'll still need the actual head of a journal, preferably from a run w/o noaer but maybe it's possible to spot the problem despite.

Offline

#7 2024-02-13 18:32:17

jfab
Member
Registered: 2024-02-11
Posts: 9

Re: Cpu usage over 200% on fresh installation of arch

I added the kernel parameter and journalctl outputs the same things

Offline

#8 2024-02-13 19:59:45

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Cpu usage over 200% on fresh installation of arch

We'll still need a full journal - did you try to boot the LTS kernel?
You could also boot "noacpi", but that will prevent a couple of features (proper rebooting) and also not give us any hint about what's causing this.

For google:

Feb 13 08:08:03 jfab kernel: ACPI Error: No handler or method for GPE 0A, disabling event (20230628/evgpe-839)
Feb 13 08:08:03 jfab kernel: ACPI Error: No handler or method for GPE 0B, disabling event (20230628/evgpe-839)
Feb 13 08:08:03 jfab kernel: ACPI Error: No installed handler for fixed event - PM_Timer (0), disabling (20230628/evevent-255)
Feb 13 08:08:03 jfab kernel: ACPI Error: No installed handler for fixed event - PowerButton (2), disabling (20230628/evevent-255)
Feb 13 08:08:03 jfab kernel: ACPI Error: No installed handler for fixed event - SleepButton (3), disabling (20230628/evevent-255)
Feb 13 08:08:03 jfab kernel: ACPI Error: Could not disable RealTimeClock events (20230628/evxfevnt-243)

Offline

#9 2024-02-13 20:27:08

jfab
Member
Registered: 2024-02-11
Posts: 9

Re: Cpu usage over 200% on fresh installation of arch

I added noacpi and booted with the LTS kernel with no luck. Nothing changes and even though the option "noacpi" is added, I still get ACPI errors on journalctl. In powertop, acpi and systemd-journald are still the top processes. An average of 200% CPU use. This is a fresh minimal arch install.

Adding the option pci=nommconf doesnt help either, and it makes the computer not start. I found this advice on https://askubuntu.com/questions/1171355 … -evgpe-835 with a similar issue on ubuntu.

Last edited by jfab (2024-02-13 20:40:05)

Offline

#10 2024-02-13 20:39:54

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Cpu usage over 200% on fresh installation of arch

Sorry "pci=noacpi" or "acpi=off", noacpi is long gone…
You can also try "pci=nommconf"

Last edited by seth (2024-02-13 20:40:47)

Offline

#11 2024-02-13 20:40:48

jfab
Member
Registered: 2024-02-11
Posts: 9

Re: Cpu usage over 200% on fresh installation of arch

I added also acpi=off and still no difference. "pci=nommconf" makes the computer not start.

Offline

#12 2024-02-13 20:43:22

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Cpu usage over 200% on fresh installation of arch

Try "pci=noacpi" and we'll need a complete journal. Not just the tail showing the failure.
In doubt check what parameters manjaro added to the commandline and make sure that you're actually effectively adding those parameters (cat /proc/cmdline)

Oh, and cc: is there a parallel windows installation?

Last edited by seth (2024-02-13 20:44:40)

Offline

#13 2024-02-13 20:51:43

jfab
Member
Registered: 2024-02-11
Posts: 9

Re: Cpu usage over 200% on fresh installation of arch

There is no parallel windows installation, it is a fresh arch install, I wiped all the disk. What do you mean about manjaro adding parameters? I already uninstalled manjaro. How do I upload the complete journal? I wrote "sudo journalctl -b | curl -F 'file=@-' 0x0.st" and the command terminated with that output.

Offline

#14 2024-02-13 21:06:37

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Cpu usage over 200% on fresh installation of arch

Feb 13 08:08:03 jfab systemd-journald[178]: Missed 204956 kernel messages

The acpi might be spamming the journal so fast that you're loosing the entire relevant part…

Does "pnpacpi=off" help?

Offline

#15 2024-02-13 21:24:13

jfab
Member
Registered: 2024-02-11
Posts: 9

Re: Cpu usage over 200% on fresh installation of arch

After adding pnpacpi=off, the computer doesn't respond. (When trying to login, the keyboard and the tty freeze)

Offline

#16 2024-02-13 22:05:06

seth
Member
Registered: 2012-09-03
Posts: 48,398

Re: Cpu usage over 200% on fresh installation of arch

Do you have a "PNP OS" like BIOS option? Or an external keyboard? Or does it help to also add "i8042.dumbkbd"?
Also do you use any kind of "acpi_osi=" override? (The general kernel commandline would be useful to see)

Offline

#17 2024-02-15 00:29:06

jfab
Member
Registered: 2024-02-11
Posts: 9

Re: Cpu usage over 200% on fresh installation of arch

Here is a photo of the kernel options: https://ibb.co/YQsHWRt

Adding the option i8042.dumbkbd does not help.

Offline

Board footer

Powered by FluxBB