You are not logged in.

#1 2024-02-12 00:18:16

Registered: 2015-09-26
Posts: 9

[Steam][Proton] Games that depend on .Net Framework not loading

I am trying to debug a couple games (Bannerlords, EliteDangerous - both work on a previous arch install on older hardware) not loading on proton/steam. I noticed both games that fail to load depend on .Net Framework.

I see with protontricks that .Net Framework is not installed in the wine prefix. Trying to install it with winetrick fails. But installing the .net framework on a clean prefix outside of the steam created one works.

All I see when running steam on the command line is a message indicating that it is creating the prefix.

Proton: Upgrading prefix from None to GE-Proton8-24

For reference, this is the error when proton loads up the game:

3190.159:0114:0118:err:module:fixup_imports_ilonly mscoree.dll not found, IL-only binary L"EDLaunch.exe" cannot be loaded
3190.159:0114:0118:err:module:LdrInitializeThunk Importing dlls for L"Z:\\home\\user\\.local\\share\\Steam\\steamapps\\common\\Elite Dangerous\\EDLaunch.e\
xe" failed, status c0000135

When running protontricks uninstaller, it does not show any install for the .net framework. It shows "Wine Mono Windows Support".
mscoree.dll is there in the c:\windows\system32 folder. Having wine-mono package installed did not help.

I suspect there is something going wrong when steam creates the prefix for the first time. At least I'd like to check if it is attempting a .net framework install and whether there are errors.

Where to find the logs for the prefix creation?



#2 2024-02-12 07:12:08

Registered: 2019-05-10
Posts: 943

Re: [Steam][Proton] Games that depend on .Net Framework not loading

Try Proton Experimental and/or downgrading Steam Linux Runtime 3.0 (sniper) (in case you're using it).

(there's latest GE-Proton8-32)

<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.


#3 2024-02-19 00:42:19

Registered: 2015-09-26
Posts: 9

Re: [Steam][Proton] Games that depend on .Net Framework not loading

Thank you for the suggestions.

I tried Proton Experimental, v8 (sniper linux runtime), v7 (soldier linux runtime) and pretty much all older proton versions Steam lets me pick.
I also tried the latest GE-Proton. Neither helped.

A few more pointers as I tried to debug this:

- Other Proton games that do not seem to depend on .net framework works, e.g. Mordhau, Far Cry 5
- Additional games that depend on .net framework do not work: Terraria
- I was able to install Elite Dangerous through Lutris and it works (this is one of the games that do not work through Steam). This indicates that there is something off with Steam/Proton, and not the system (or so this is my interpretation)
- In the games proton prefix I cannot install net40 / net48 / vcrun2015.
- But I can create a brand new wine prefix and install all those
- Debug logs for the steam linux runtime ( … do not show me any errors - but I still cannot find a way to get the PROTON/wine logs for post-install script setup

Not really sure what to try next, but if I find any other insights I will post here.


#4 2024-02-19 11:59:55

Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,351

Re: [Steam][Proton] Games that depend on .Net Framework not loading

lutris install scripts often help to figure out what they do different then others . lists 6 options , which did you use ?
(Need to see the used script, so if you chose auto this approach won't help much)

Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

clean chroot building to complicated ?
Try clean chroot manager by graysky


Board footer

Powered by FluxBB