You are not logged in.

#1 2024-02-16 13:17:32

dhruv8sh
Member
Registered: 2021-10-15
Posts: 9

System broke after last update

I have kde-unstable enabled, today I did my periodical pacman -Syu.

I remember it downloaded breeze and some qt6 related packages, now the system won't get past the login. SDDM is using its fallback theme.

Shows the error(shortened):
Cannot load breeze/Main.qml,
Cannot load breeze/components/WallpaperFader.qml,
Cannot load /use/lib/qt6/qml/org/kde/plasma/private/sessions/libsessionsprivateplugin.so (/use/lib/libPlasma.so.6: undefined symbol: _ZNK11QMetaObject17indexOfEnumeratorE14QByteArrayView, version Qt_6)


Furthermore, went into tty, connected back to wifi, still cannot ping www.google.com, meaning cannot download anything from Pacman anymore.
Showing temporary failure in name resolution.

My bad for the bad formatting, I'm on a phone.

Offline

#2 2024-02-16 13:27:18

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,835
Website

Re: System broke after last update

Mod note: moving to testing.


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2024-02-16 13:35:16

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,616

Re: System broke after last update

Things are in the process of getting rebuilt for the new Qt 6 release right now, try again in a couple minutes/few hours.

Last edited by V1del (2024-02-16 13:35:34)

Offline

#4 2024-02-16 14:49:26

sergekorol
Member
Registered: 2021-04-13
Posts: 18

Re: System broke after last update

V1del wrote:

Things are in the process of getting rebuilt for the new Qt 6 release right now, try again in a couple minutes/few hours.

Can you please put out an update when it is safe to do this upgrade?

Last edited by sergekorol (2024-02-16 14:49:41)

Offline

#5 2024-02-16 15:03:26

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,616

Re: System broke after last update

I'm not building things, I just noticed that rebuilds are happening. Maybe arojas will pop in and give you an exact time, other than that monitor the "latest packages" webpage/RSS feeds and update when you don't see a new KDE/Qt dep getting introduced by the minute.

Last edited by V1del (2024-02-16 15:03:37)

Offline

#6 2024-02-16 15:37:50

sergekorol
Member
Registered: 2021-04-13
Posts: 18

Re: System broke after last update

V1del wrote:

I'm not building things, I just noticed that rebuilds are happening. Maybe arojas will pop in and give you an exact time, other than that monitor the "latest packages" webpage/RSS feeds and update when you don't see a new KDE/Qt dep getting introduced by the minute.

Yea sorry

Maybe he will put out a post then. I had to timeshift earlier to get a working kde back.

Offline

#7 2024-02-16 20:39:36

sergekorol
Member
Registered: 2021-04-13
Posts: 18

Re: System broke after last update

Well it seems to be working ok now. except for dolphin.
dolphin                                                                                  ~
dolphin: symbol lookup error: dolphin: undefined symbol: _Zls6QDebugRK11QDockWidget, version Qt_6

I downloaded and ran makepkg -si dolphin and installed a working dolphin, so I suppose my mirror hasn't been updated yet.

Last edited by sergekorol (2024-02-16 21:37:51)

Offline

Board footer

Powered by FluxBB