You are not logged in.

#1 2007-01-29 19:33:10

Registered: 2006-05-05
Posts: 25

[SOLVED] Sound issue (Nvidia HDA/Realtek ALC880)

I recently bought a ASUS A7M notebook, I could buy this sweet darling with Suse 10.1 preinstalled... Everything worked fine but Suse is just way to slow for this modern laptop... So I decided to install arch...  The performance and speed are magical compared to Suse aldoh I have a problem installing the sound device.

Here are the specs of the notebook: … df7.0.html

After installing arch, adding myself to the audio group and setting up alsa I still have no decent sound...
when I plug in my headphones I hear sound, both alsa and oss seem to work but the sound is verry dirty and noisy ... My speakers don't give any sound... Is this an module-issue?

My sounddevice should be Realtek/Nvidia HDA

lsmod | grep snd
snd_seq_oss            29440  0 
snd_seq_midi_event      6528  1 snd_seq_oss
snd_seq                47056  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          6796  2 snd_seq_oss,snd_seq
snd_pcm_oss            38944  0 
snd_mixer_oss          14464  1 snd_pcm_oss
snd_hda_intel          15768  2 
snd_hda_codec         156800  1 snd_hda_intel
snd_pcm                68612  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              18948  2 snd_seq,snd_pcm
snd                    44004  13 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
soundcore               6624  1 snd
snd_page_alloc          7816  2 snd_hda_intel,snd_pcm
lspci|grep Audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

Please Help!

Last edited by Gentleman (2007-01-31 18:38:56)


#2 2007-01-31 18:42:02

Registered: 2006-05-05
Posts: 25

Re: [SOLVED] Sound issue (Nvidia HDA/Realtek ALC880)

After an aggressive google-search I found the solution...

I reloaded the "snd_hda_intel" module with "model=asus".

modprobe snd_hda_intel model=asus

Everything works fine now cool


Board footer

Powered by FluxBB