You are not logged in.

#1 2007-01-29 21:14:44

Mo
Member
Registered: 2007-01-18
Posts: 92

Some amixer-commands are not working.

Hello, some of the commands of amixer are not working for me, e.g. "amixer set PCM toggle" or "amixer set PCM mute". But other commands like "amixer set PCM 100%+" work fine. How can I change this? Especially I want to use the toggle-command for the hotkey on my laptop.

Greets, Mo.

Offline

#2 2007-01-29 22:17:11

skale
Member
From: Atlanta, GA
Registered: 2006-08-04
Posts: 146

Re: Some amixer-commands are not working.

does sset instead of set work?  Both should work, but if we are pulling for straws, might as well try.

Alternatively, are you as a user in the "audio' group?  If not, that might be your problem.

Offline

#3 2007-01-29 22:25:34

Mo
Member
Registered: 2007-01-18
Posts: 92

Re: Some amixer-commands are not working.

Thanks for your help, but sset does not work sad. And I am a user in the audio group... So what else could help?

Last edited by Mo (2007-01-29 22:27:26)

Offline

#4 2007-01-29 23:33:46

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,694
Website

Re: Some amixer-commands are not working.

try "set Master toggle" in case that PCM for some reason is not responidng.

R

Offline

#5 2007-01-30 06:34:00

Mo
Member
Registered: 2007-01-18
Posts: 92

Re: Some amixer-commands are not working.

mo ~> amixer set Master toggle
amixer: Unable to find simple control 'Master',0

I think that PCM should work because it also works with "amixer set PCM 100%-".

Offline

#6 2007-01-30 20:58:36

skale
Member
From: Atlanta, GA
Registered: 2006-08-04
Posts: 146

Re: Some amixer-commands are not working.

use `alsamixer` and see what is happening.

Offline

#7 2007-01-30 21:19:48

Mo
Member
Registered: 2007-01-18
Posts: 92

Re: Some amixer-commands are not working.

I'm able to control my sound via alsamixer...

Offline

Board footer

Powered by FluxBB