You are not logged in.

#1 2024-03-13 01:07:27

Registered: 2023-11-14
Posts: 9

Wifi not working on lenovo ideapad laptop Realtek 8852BE RTL8852BE

Trying to install arch linux on my lenovo ideapad slim 3.  Initial attempts at getting wifi to work were going into iwctl and at the device <device> set-property Powered on Step I encountered a "Operation failed" error.

I created a custom arch iso that included the most recent rtw89-dkms-git package.  I built this package custom with the modifications described in the comment by uncle sam here

I created the custom arch iso with a local repo that contained my version of the dkms package, and a modified packages file so that rtw89-dkms-git had all of its dependencies.

Trying iwctl with this custom iso i was met with the same issue, then I found this wiki and tried the steps under wifi … m_3_16ABR8

I ran
   rmmod rtw89_8852be #because the other one depends on this coming first
   rmmod rtw89_pci
   modprobe rtw89_pci disable_aspm_l1=y disable_aspm_l1ss=y
   modprobe rtw89_8852be

after this i was met with the same "Operation Failed" error.  Short of getting an ethernet adapter, what can i try next? I have a functionaing arch desktop i'm using.

Laptop Wiki: … m_3_16ABR8
Comment Thread:

Last edited by gabespound (2024-03-14 02:07:35)


Board footer

Powered by FluxBB