You are not logged in.

#1 2007-02-01 05:31:49

sodface
Member
Registered: 2005-12-26
Posts: 38

Some Install Notes LVM2, Net etc.

I had a couple of minor problems getting my FTP install going tonight and thought I might post up my resolutions since I didn't really see them verbatim during the brief searches I did.

It's been quite a while since I've done any linux install so I was a bit rusty, but, I like the quickinst method of manually creating partitions, file systems, then moutning etc.

This install was nothing fancy.  A single hard disk at /dev/sda.  The only twist was that I wanted to use LVM2 on one partition /dev/sda4.  /boot swap and / will be mounted on /dev/sda1 /sda2 and /sda3 respectively.

cfdisk went fine as normal.

Then for the lvm stuff:

lvm pvcreate /dev/sda4

This worked fine.

lvm vgcreate vg01 /dev/sda4

This worked fine.

lvm lvcreate -L 3G -n usr vg01

This Failed.  All it did was output the lvm lvcreate help so fast that I couldn't see the error message before it scrolled off the screen.  Piping into more or less didn't help either but I think that was operator error somehow.

To cut to the chase, in order to create the logical volumes with lvm lvcreate, I had to load device-mapper:

modprobe dm-mod

After this I was able to create the logical volumes and then file systems.

The other problem I had was network related.  I'm using an Aopen board with an integrated Realtek gigabit nic.  Everything looked fine to me at first.  ifconfig showed eth0.  I set the IP address but couldn't ping anything on the LAN.

I ended up throwing in a 10/100 PCI 3com 3c905TX I had laying around.  I had to:

modprobe 3c59x

to load the nic driver and then I had eth1 available.  I set the IP on that and everything was good.  I haven't done much research on the Realtek gigabit nic but I have a feeling it could be an autonegotiation problem maybe?

Anyway, that's it.


//edit
The modprobe dm-mod step is listed here:
http://wiki.archlinux.org/index.php/Ins … AID_or_LVM
I'm actually listed in the credits of that article... heh oops.  Though Paul's done an excellent job keeping it up to date with each release.  I don't remember that dm-mod step always being necessary.

Last edited by sodface (2007-02-01 05:39:55)

Offline

#2 2007-02-01 06:38:36

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: Some Install Notes LVM2, Net etc.

makes me wonder if you used the new ISO located here:
http://www.archlinux.org/news/283/

Offline

#3 2007-02-01 06:46:00

sodface
Member
Registered: 2005-12-26
Posts: 38

Re: Some Install Notes LVM2, Net etc.

No, I used the 0.7.2 FTP ISO.

Offline

Board footer

Powered by FluxBB