You are not logged in.

#1 2024-04-01 20:01:50

Registered: 2024-04-01
Posts: 1

HP T620 hardware video acceleration


I've used the installation guide to successfully install arch on an HP T620 thin client.
Everything works perfectly out of the box except hardware video acceleration. The system has a GX-217GA SOC which includes a Radeon HD 8280E.

I've installed libva-mesa-driver as mentioned in the hardware video acceleration wiki page.
The output of vainfo suggests that has worked and picked up the the h.264 decoding capability

Trying display: wayland
Trying display: x11
error: can't connect to X server!
Trying display: drm
vainfo: VA-API version: 1.21 (libva 2.21.0)
vainfo: Driver version: Mesa Gallium driver 24.0.4-arch1.1 for KABINI (radeonsi, , LLVM 17.0.6, DRM 2.50, 6.6.23-1-lts)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc

I can also see in logs that the radeon driver seems to load correctly and also loads the kabini microcode, which corresponds to this SOC.

kernel: [drm] radeon kernel modesetting enabled.
kernel: radeon 0000:00:01.0: vgaarb: deactivate vga console
kernel: [drm] initializing kernel modesetting (KABINI 0x1002:0x9837 0x103C:0x2187 0x00).
kernel: [drm] doorbell mmio base: 0xD0000000
kernel: [drm] doorbell mmio size: 8388608
kernel: ATOM BIOS: HP
kernel: radeon 0000:00:01.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
kernel: radeon 0000:00:01.0: GTT: 2048M 0x0000000020000000 - 0x000000009FFFFFFF
kernel: [drm] Detected VRAM RAM=512M, BAR=256M
kernel: [drm] RAM width 128bits DDR
kernel: [drm] radeon: 512M of VRAM memory ready
kernel: [drm] radeon: 2048M of GTT memory ready.
kernel: [drm] Loading kabini Microcode
kernel: [drm] Internal thermal controller without fan control
kernel: [drm] radeon: dpm initialized
kernel: [drm] Found UVD firmware Version: 1.64 Family ID: 9
kernel: [drm] Found VCE firmware/feedback version 40.2.2 / 15!
kernel: [drm] GART: num cpu pages 524288, num gpu pages 524288
kernel: [drm] PCIE GART of 2048M enabled (table at 0x000000000030E000).
kernel: radeon 0000:00:01.0: WB enabled
kernel: radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000020000c00
kernel: radeon 0000:00:01.0: fence driver on ring 1 use gpu addr 0x0000000020000c04
kernel: radeon 0000:00:01.0: fence driver on ring 2 use gpu addr 0x0000000020000c08
kernel: radeon 0000:00:01.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c
kernel: radeon 0000:00:01.0: fence driver on ring 4 use gpu addr 0x0000000020000c10
kernel: radeon 0000:00:01.0: fence driver on ring 5 use gpu addr 0x0000000000078d30
kernel: radeon 0000:00:01.0: fence driver on ring 6 use gpu addr 0x0000000020000c18
kernel: radeon 0000:00:01.0: fence driver on ring 7 use gpu addr 0x0000000020000c1c
kernel: radeon 0000:00:01.0: radeon: using MSI.
kernel: [drm] radeon: irq initialized.

However, in kodi (using the gbm composer) if I play an h.264 file and press "o", then it shows "ffmpeg-h264 (SW)" as the decoder. I can see the cpu usage is relatively high, and depending on the video file, the cpu usage can be maxed out and the video stutter.

I've tried running xorg kodi, explicitly setting the "LIBVA_DRIVER_NAME=radeonsi" environment variable, ensuring hardware video acceleration is selected in Kodi under Settings > Player > Videos. But without success.

Does anyone have any suggestions as to what the problem might be?


Board footer

Powered by FluxBB