You are not logged in.

#1 2024-04-03 19:16:28

trout420
Member
Registered: 2022-11-30
Posts: 29

Qt6 Dependency for pinentry

After an update of the pinentry package yesterday, I was unable to use pinentry-qt due to missing qt6 libraries (libQt6Widgets.so.6). I was able to solve this problem by installing qt6-base, but checking the dependencies listed on the pinentry package it still lists qt5 (along with some qt5 extras) as what is needed for pinentry-qt. I was able to somewhat confirm that the qt frontend is no longer dependent on qt5 by uninstalling all qt5 libs on my machine. The repository for pinenetry still states that the program is dependent on ">Qt4.4.0" and looking at their git log it looks like there is still work actively being done on qt5, but I do not fully understand how I am able to run the qt frontend without qt5 and only qt6.

My questions from here are: should the package be updated to list qt6 as a dependency? can qt5 (along with the other libraries) be removed as dependencies? Are either of these actions good ideas? How would one go about doing this? I would like to contribute to this, and not just hurl a half baked request at the package maintainers.

Please let me know if there is anything I am missing.

Offline

#2 2024-04-03 19:32:10

progandy
Member
Registered: 2012-05-17
Posts: 5,218

Re: Qt6 Dependency for pinentry

The repository for pinenetry still states that the program is dependent on ">Qt4.4.0" and looking at their git log it looks like there is still work actively being done on qt5, but I do not fully understand how I am able to run the qt frontend without qt5 and only qt6.

It means the source code works with qt4, qt5 and qt6. The most recent arch package is compiled with qt6, so it only works with that, but the optional dependencies have not been updated to reflect those makedepends changes.
https://gitlab.archlinux.org/archlinux/ … a857be272d

Yes, the package should be updated to the qt6 dependencies.

Last edited by progandy (2024-04-03 19:34:13)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#3 2024-04-03 19:37:19

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,893
Website

Re: Qt6 Dependency for pinentry

trout420 wrote:

How would one go about doing this? I would like to contribute to this, and not just hurl a half baked request at the package maintainers.

It seems properly baked to me and is appropriate to be sent to our bug tracker as a packaging issue if it has not already been reported there.


"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman

Online

Board footer

Powered by FluxBB