You are not logged in.

#1 2024-04-05 16:03:10

daniel_shub
Member
Registered: 2012-06-21
Posts: 85

[SOLVED] Pacman fails to fetch signatures with custom XferCommand

I use pacman with one of the commented out XferCommand from the default /etc/pacman.conf:

XferCommand = /usr/bin/curl -L -C - -f -o %o %u

I am not sure why I am using this command, but I have been doing it for years. I think originally I was adding extra flags to work around a proxy server, but at this point the reasoning is lost to time ...

When I run

sudo pacman -Syu

I get lots of errors like

error: cockpit-machines: missing required signature

where each error has a different package name. If I comment out the XferCommand everything works ok. I think my issue might be related to this recent patch: https://gitlab.archlinux.org/pacman/pacman/-/issues/14 but am not sure.

For completeness, I am hosting my own local pacman cache with pacoloco and updating the mirrors that pacoloco uses with reflector, so there could be other causes.

Last edited by daniel_shub (2024-04-06 13:03:45)

Offline

#2 2024-04-05 23:09:46

Allan
Pacman
From: Brisbane, AU
Registered: 2007-06-09
Posts: 11,439
Website

Re: [SOLVED] Pacman fails to fetch signatures with custom XferCommand

https://gitlab.archlinux.org/pacman/pac … 56528f9b50

This is the fix. It has not been backported by Arch yet

Offline

Board footer

Powered by FluxBB