You are not logged in.

#1 2024-04-07 09:28:02

manlio.perillo
Member
Registered: 2024-04-07
Posts: 4

[SOLVED] Unable to update kernel after previous system update

Here is the pacman log.
This seems a pacman bug but I'm not sure.  The result is that I'm unable to install a new kernel.

[2024-04-03T09:49:41+0200] [ALPM] transaction started
[2024-04-03T09:49:41+0200] [ALPM] upgraded btrfs-progs (6.8-1 -> 6.8-2)
[2024-04-03T09:49:56+0200] [ALPM] upgraded libtiff (4.6.0-2 -> 4.6.0-4)
[2024-04-03T09:49:56+0200] [ALPM] upgraded shadow (4.15.1-1 -> 4.15.1-2)
[2024-04-03T09:49:57+0200] [ALPM] upgraded chromium (123.0.6312.86-2 -> 123.0.6312.105-1)
[2024-04-03T09:49:57+0200] [ALPM] upgraded dmenu (5.3-1 -> 5.3-2)
[2024-04-03T09:49:59+0200] [ALPM] upgraded firefox (124.0.1-1 -> 124.0.2-1)
[2024-04-03T09:49:59+0200] [ALPM] upgraded firefox-i18n-it (124.0.1-1 -> 124.0.2-1)
[2024-04-03T09:49:59+0200] [ALPM] upgraded i3-wm (4.23-1 -> 4.23-3)
[2024-04-03T09:49:59+0200] [ALPM] upgraded libuv (1.48.0-1 -> 1.48.0-2)
[2024-04-03T09:49:59+0200] [ALPM] upgraded python-contourpy (1.2.0-1 -> 1.2.1-1)
[2024-04-03T09:50:00+0200] [ALPM] upgraded telegram-desktop (4.16.0-1 -> 4.16.1-1)
[2024-04-03T09:50:01+0200] [ALPM] upgraded wasmtime (19.0.0-1 -> 19.0.1-1)
[2024-04-03T09:50:01+0200] [ALPM] transaction completed
[2024-04-03T09:50:01+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2024-04-03T09:50:01+0200] [ALPM] running '30-systemd-daemon-reload-system.hook'...
[2024-04-03T09:50:02+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2024-04-03T09:50:02+0200] [ALPM] running '30-systemd-udev-reload.hook'...
[2024-04-03T09:50:10+0200] [ALPM] running '30-systemd-update.hook'...
[2024-04-03T09:50:10+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET] ==> Starting build: '6.8.2-arch2-1'
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2024-04-03T09:50:11+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'xhci_pci'
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: '/boot/initramfs-linux.img'
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET] ==> Initcpio image generation successful
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET] ==> Starting build: '6.8.2-arch2-1'
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2024-04-03T09:50:12+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2024-04-03T09:50:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2024-04-03T09:50:13+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2024-04-03T09:50:13+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'aic94xx'
[2024-04-03T09:50:13+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'bfa'
[2024-04-03T09:50:14+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'qed'
[2024-04-03T09:50:14+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'qla1280'
[2024-04-03T09:50:14+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'qla2xxx'
[2024-04-03T09:50:14+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'wd719x'
[2024-04-03T09:50:14+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: 'xhci_pci'
[2024-04-03T09:50:15+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2024-04-03T09:50:16+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2024-04-03T09:50:18+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2024-04-03T09:50:18+0200] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: '/boot/initramfs-linux-fallback.img'
[2024-04-03T09:50:20+0200] [ALPM-SCRIPTLET] ==> Initcpio image generation successful
[2024-04-03T09:50:20+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2024-04-03T09:50:20+0200] [ALPM] running 'update-desktop-database.hook'...
[2024-04-06T17:33:30+0200] [PACMAN] Running '/usr/bin/pacman -Syu'
[2024-04-06T17:33:30+0200] [PACMAN] synchronizing package lists
[2024-04-06T17:33:32+0200] [PACMAN] starting full system upgrade
[2024-04-06T17:34:12+0200] [ALPM] transaction started
[2024-04-06T17:34:12+0200] [ALPM] upgraded curl (8.7.1-4 -> 8.7.1-5)
[2024-04-06T17:34:12+0200] [ALPM] upgraded cmake (3.29.0-1 -> 3.29.1-1)
[2024-04-06T17:34:13+0200] [ALPM] upgraded containerd (1.7.14-1 -> 1.7.15-1)
[2024-04-06T17:34:13+0200] [ALPM] upgraded github-cli (2.46.0-1 -> 2.47.0-1)
[2024-04-06T17:34:14+0200] [ALPM] upgraded gnutls (3.8.4-1 -> 3.8.5-1)
[2024-04-06T17:34:17+0200] [ALPM] upgraded go (2:1.22.1-1 -> 2:1.22.2-1)
[2024-04-06T17:34:17+0200] [ALPM] upgraded pcre2 (10.43-1 -> 10.43-2)
[2024-04-06T17:34:17+0200] [ALPM] upgraded libx11 (1.8.8-3 -> 1.8.9-1)
[2024-04-06T17:34:17+0200] [ALPM] upgraded gtk-update-icon-cache (1:4.14.1-1 -> 1:4.14.2-1)
[2024-04-06T17:34:30+0200] [ALPM] upgraded libunwind (1.8.1-1 -> 1.8.1-2)
[2024-04-06T17:34:30+0200] [ALPM] upgraded hwdata (0.380-1 -> 0.381-1)
[2024-04-06T17:34:30+0200] [ALPM] upgraded gtk4 (1:4.14.1-1 -> 1:4.14.2-1)
[2024-04-06T17:34:30+0200] [ALPM] upgraded lib32-curl (8.7.1-3 -> 8.7.1-4)
[2024-04-06T17:34:30+0200] [ALPM] upgraded libassuan (2.5.7-1 -> 2.5.7-2)
[2024-04-06T17:34:30+0200] [ALPM] upgraded libdispatch (5.5.0-1 -> 5.10-1)
[2024-04-06T17:34:30+0200] [ALPM] upgraded libtorrent-rasterbar (1:2.0.9-3 -> 1:2.0.10-1)
[2024-04-06T17:34:30+0200] [ALPM] upgraded mesa-utils (9.0.0-3 -> 9.0.0-4)
[2024-04-06T17:34:31+0200] [ALPM] upgraded nodejs (21.7.1-1 -> 21.7.2-1)
[2024-04-06T17:34:31+0200] [ALPM] upgraded npm (10.5.0-1 -> 10.5.1-1)
[2024-04-06T17:34:31+0200] [ALPM] upgraded otf-firamono-nerd (3.1.1-1 -> 3.2.0-1)
[2024-04-06T17:34:32+0200] [ALPM] upgraded patchelf (0.18.0-1 -> 0.18.0-2)
[2024-04-06T17:34:32+0200] [ALPM] upgraded python-build (1.1.1-2 -> 1.2.1-1)
[2024-04-06T17:34:32+0200] [ALPM] upgraded python-fonttools (4.50.0-1 -> 4.51.0-1)
[2024-04-06T17:34:32+0200] [ALPM] upgraded python-matplotlib (3.8.3-1 -> 3.8.3-2)
[2024-04-06T17:34:32+0200] [ALPM] upgraded python-parso (1:0.8.3-2 -> 1:0.8.4-1)
[2024-04-06T17:34:32+0200] [ALPM] upgraded python-pycparser (2.21-5 -> 2.22-1)
[2024-04-06T17:34:32+0200] [ALPM] upgraded python-pyudev (0.24.1-1 -> 0.24.1-2)
[2024-04-06T17:34:33+0200] [ALPM] upgraded qt5-webengine (5.15.16-5 -> 5.15.16-6)
[2024-04-06T17:34:33+0200] [ALPM] upgraded soundtouch (2.3.2-1 -> 2.3.3-1)
[2024-04-06T17:34:33+0200] [ALPM] upgraded tcl (8.6.14-2 -> 8.6.14-3)
[2024-04-06T17:34:33+0200] [ALPM] upgraded tree-sitter-bash (0.21.0-1 -> 0.21.0-2)
[2024-04-06T17:34:33+0200] [ALPM] upgraded tree-sitter-c (0.21.0-1 -> 0.21.0-2)
[2024-04-06T17:34:33+0200] [ALPM] upgraded tree-sitter-lua (0.1.0-1 -> 0.1.0-2)
[2024-04-06T17:34:33+0200] [ALPM] upgraded tree-sitter-markdown (0.2.3-1 -> 0.2.3-2)
[2024-04-06T17:34:33+0200] [ALPM] upgraded tree-sitter-python (0.21.0-1 -> 0.21.0-2)
[2024-04-06T17:34:33+0200] [ALPM] upgraded tree-sitter-query (0.2.1-1 -> 0.2.1-2)
[2024-04-06T17:34:33+0200] [ALPM] upgraded tree-sitter-vimdoc (2.5.1-1 -> 2.5.1-2)
[2024-04-06T17:34:33+0200] [ALPM] upgraded typescript (5.4.3-1 -> 5.4.4-1)
[2024-04-06T17:34:33+0200] [ALPM] upgraded xorg-server-common (21.1.11-2 -> 21.1.12-1)
[2024-04-06T17:34:33+0200] [ALPM] upgraded xorg-server (21.1.11-2 -> 21.1.12-1)
[2024-04-06T17:34:34+0200] [ALPM] transaction completed
[2024-04-06T17:34:35+0200] [ALPM] running '30-systemd-daemon-reload-system.hook'...
[2024-04-06T17:34:35+0200] [ALPM] running '30-systemd-update.hook'...
[2024-04-06T17:34:35+0200] [ALPM] running '30-update-mime-database.hook'...
[2024-04-06T17:34:36+0200] [ALPM] running 'fontconfig.hook'...
[2024-04-06T17:34:36+0200] [ALPM] running 'fontconfig-32.hook'...
[2024-04-06T17:34:36+0200] [ALPM] running 'glib-compile-schemas.hook'...
[2024-04-06T17:34:36+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2024-04-06T17:34:37+0200] [ALPM] running 'gtk4-querymodules.hook'...
[2024-04-06T17:34:37+0200] [ALPM] running 'texinfo-install.hook'...
[2024-04-06T17:34:37+0200] [ALPM] running 'update-desktop-database.hook'...
[2024-04-06T17:34:37+0200] [ALPM] running 'xorg-mkfontscale.hook'...
[2024-04-07T10:14:55+0200] [PACMAN] Running '/usr/bin/pacman -Syu'
[2024-04-07T10:14:55+0200] [PACMAN] synchronizing package lists
[2024-04-07T10:14:57+0200] [PACMAN] starting full system upgrade
[2024-04-07T10:15:35+0200] [ALPM] running '60-mkinitcpio-remove.hook'...
[2024-04-07T10:15:47+0200] [ALPM] transaction started
[2024-04-07T10:15:47+0200] [ALPM] upgraded coin-or-coinutils (2.11.10-1 -> 2.11.11-1)
[2024-04-07T10:15:47+0200] [ALPM] upgraded geoip-database (20240309-1 -> 20240406-1)
[2024-04-07T10:15:47+0200] [ALPM] upgraded libnghttp2 (1.60.0-1 -> 1.61.0-1)
[2024-04-07T10:15:47+0200] [ALPM] upgraded lib32-libnghttp2 (1.60.0-1 -> 1.61.0-1)
[2024-04-07T10:15:47+0200] [ALPM] upgraded libibus (1.5.29-3 -> 1.5.29-4)
[2024-04-07T10:15:49+0200] [ALPM] upgraded linux (6.8.2.arch2-1 -> 6.8.4.arch1-1)
[2024-04-07T10:15:49+0200] [ALPM] upgraded man-db (2.12.0-1 -> 2.12.1-1)
[2024-04-07T10:15:49+0200] [ALPM] upgraded python-argcomplete (2.0.0-2 -> 3.1.1-1)
[2024-04-07T10:15:49+0200] [ALPM] transaction completed
[2024-04-07T10:15:49+0200] [ALPM] running '30-systemd-daemon-reload-system.hook'...
[2024-04-07T10:15:50+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2024-04-07T10:15:50+0200] [ALPM] running '30-systemd-update.hook'...
[2024-04-07T10:15:50+0200] [ALPM] running '60-depmod.hook'...
[2024-04-07T10:15:52+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2024-04-07T10:15:53+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2024-04-07T10:15:53+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:15:53+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2024-04-07T10:15:53+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:15:53+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2024-04-07T10:15:53+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:15:53+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2024-04-07T10:15:53+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:16:34+0200] [PACMAN] Running '/usr/bin/pacman -Syu'
[2024-04-07T10:16:34+0200] [PACMAN] synchronizing package lists
[2024-04-07T10:16:34+0200] [PACMAN] starting full system upgrade
[2024-04-07T10:16:52+0200] [PACMAN] Running '/usr/bin/pacman -Syu linux-6.8.4.arch1-1'
[2024-04-07T10:16:52+0200] [PACMAN] synchronizing package lists
[2024-04-07T10:18:19+0200] [PACMAN] Running '/usr/bin/pacman -Syu linux'
[2024-04-07T10:18:19+0200] [PACMAN] synchronizing package lists
[2024-04-07T10:18:19+0200] [PACMAN] starting full system upgrade
[2024-04-07T10:18:26+0200] [ALPM] transaction started
[2024-04-07T10:18:27+0200] [ALPM] reinstalled linux (6.8.4.arch1-1)
[2024-04-07T10:18:27+0200] [ALPM] transaction completed
[2024-04-07T10:18:27+0200] [ALPM] running '30-systemd-update.hook'...
[2024-04-07T10:18:27+0200] [ALPM] running '60-depmod.hook'...
[2024-04-07T10:18:29+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:28:09+0200] [PACMAN] Running '/usr/bin/pacman -S filesystem linux'
[2024-04-07T10:28:12+0200] [ALPM] transaction started
[2024-04-07T10:28:12+0200] [ALPM] reinstalled filesystem (2024.01.19-1)
[2024-04-07T10:28:13+0200] [ALPM] reinstalled linux (6.8.4.arch1-1)
[2024-04-07T10:28:13+0200] [ALPM] transaction completed
[2024-04-07T10:28:13+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2024-04-07T10:28:14+0200] [ALPM] running '30-systemd-sysctl.hook'...
[2024-04-07T10:28:14+0200] [ALPM-SCRIPTLET] Couldn't write '0' to 'net/ipv4/conf/all/accept_redirect', ignoring: No such file or directory
[2024-04-07T10:28:14+0200] [ALPM-SCRIPTLET] Couldn't write '0' to 'net/ipv6/conf/default/accept_redirect', ignoring: No such file or directory
[2024-04-07T10:28:14+0200] [ALPM-SCRIPTLET] Couldn't write '0' to 'net/ipv6/cond/all/accept_redirecr', ignoring: No such file or directory
[2024-04-07T10:28:14+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2024-04-07T10:28:14+0200] [ALPM] running '30-systemd-update.hook'...
[2024-04-07T10:28:14+0200] [ALPM] running '60-depmod.hook'...
[2024-04-07T10:28:15+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2024-04-07T10:28:16+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2024-04-07T10:28:16+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:28:16+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2024-04-07T10:28:16+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:28:16+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2024-04-07T10:28:16+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:28:16+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2024-04-07T10:28:16+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:31:22+0200] [PACMAN] Running '/usr/bin/pacman -Syu'
[2024-04-07T10:31:22+0200] [PACMAN] synchronizing package lists
[2024-04-07T10:31:24+0200] [PACMAN] starting full system upgrade
[2024-04-07T10:34:12+0200] [PACMAN] Running '/usr/bin/pacman -S filesystem linux'
[2024-04-07T10:34:17+0200] [ALPM] transaction started
[2024-04-07T10:34:17+0200] [ALPM] reinstalled filesystem (2024.01.19-1)
[2024-04-07T10:34:17+0200] [ALPM] reinstalled linux (6.8.4.arch1-1)
[2024-04-07T10:34:18+0200] [ALPM] transaction completed
[2024-04-07T10:34:18+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2024-04-07T10:34:18+0200] [ALPM] running '30-systemd-sysctl.hook'...
[2024-04-07T10:34:18+0200] [ALPM-SCRIPTLET] Couldn't write '0' to 'net/ipv4/conf/all/accept_redirect', ignoring: No such file or directory
[2024-04-07T10:34:18+0200] [ALPM-SCRIPTLET] Couldn't write '0' to 'net/ipv6/conf/default/accept_redirect', ignoring: No such file or directory
[2024-04-07T10:34:18+0200] [ALPM-SCRIPTLET] Couldn't write '0' to 'net/ipv6/cond/all/accept_redirecr', ignoring: No such file or directory
[2024-04-07T10:34:18+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2024-04-07T10:34:18+0200] [ALPM] running '30-systemd-update.hook'...
[2024-04-07T10:34:18+0200] [ALPM] running '60-depmod.hook'...
[2024-04-07T10:34:19+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2024-04-07T10:34:20+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2024-04-07T10:34:20+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:34:20+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2024-04-07T10:34:20+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:34:20+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2024-04-07T10:34:20+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:34:20+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2024-04-07T10:34:20+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory@gmail.com

How can I fix it?

Thanks
Manlio Perillo

Last edited by manlio.perillo (2024-04-08 08:27:30)

Offline

#2 2024-04-07 10:03:29

seth
Member
Registered: 2012-09-03
Posts: 54,422

Re: [SOLVED] Unable to update kernel after previous system update

Please use [code][/code] tags. Edit your post in this regard.

[2024-04-07T10:18:19+0200] [PACMAN] Running '/usr/bin/pacman -Syu linux'
[2024-04-07T10:18:19+0200] [PACMAN] synchronizing package lists
[2024-04-07T10:18:19+0200] [PACMAN] starting full system upgrade
[2024-04-07T10:18:26+0200] [ALPM] transaction started
[2024-04-07T10:18:27+0200] [ALPM] reinstalled linux (6.8.4.arch1-1)
[2024-04-07T10:18:27+0200] [ALPM] transaction completed
[2024-04-07T10:18:27+0200] [ALPM] running '30-systemd-update.hook'...
[2024-04-07T10:18:27+0200] [ALPM] running '60-depmod.hook'...
[2024-04-07T10:18:29+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> Using configuration file: '/etc/mkinitcpio.conf'
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2024-04-07T10:18:29+0200] [ALPM-SCRIPTLET] ==> ERROR: '/lib/modules/6.8.2-arch2-1' is not a valid kernel module directory
[2024-04-07T10:28:09+0200] [PACMAN] Running '/usr/bin/pacman -S filesystem linux'
[2024-04-07T10:28:12+0200] [ALPM] transaction started
[2024-04-07T10:28:12+0200] [ALPM] reinstalled filesystem (2024.01.19-1)
[2024-04-07T10:28:13+0200] [ALPM] reinstalled linux (6.8.4.arch1-1)

You've 6.8.4 installed by end up trying to build an initramfs for (the gone) 6.8.2

file /boot/vmlinuz-linux

Offline

#3 2024-04-07 10:03:52

manlio.perillo
Member
Registered: 2024-04-07
Posts: 4

Re: [SOLVED] Unable to update kernel after previous system update

UPDATE:

I tried to downgrade the kernel (using the pacman cache), but it failed due to the boot partition being full (years ago I decided to make it 127M).
I removed the kms hook and I was able to install the previous kernel.

The problem is that I still got an error when trying to install the latest kernel.

Offline

#4 2024-04-07 10:05:55

seth
Member
Registered: 2012-09-03
Posts: 54,422

Re: [SOLVED] Unable to update kernel after previous system update

Probably the full partition prevented replacing the kernel?

Offline

#5 2024-04-08 05:59:52

manlio.perillo
Member
Registered: 2024-04-07
Posts: 4

Re: [SOLVED] Unable to update kernel after previous system update

seth wrote:

Probably the full partition prevented replacing the kernel?

I have no idea.

But today I updated the system again and it worked.

Thanks.

Offline

#6 2024-04-08 06:30:19

seth
Member
Registered: 2012-09-03
Posts: 54,422

Re: [SOLVED] Unable to update kernel after previous system update

\o/
Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

#7 2024-04-08 08:28:18

manlio.perillo
Member
Registered: 2024-04-07
Posts: 4

Re: [SOLVED] Unable to update kernel after previous system update

seth wrote:

\o/
Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Done.

Thanks for the reminder.

Offline

Board footer

Powered by FluxBB