You are not logged in.

#1 2024-05-02 04:36:27

kronyx
Member
Registered: 2024-04-23
Posts: 14

[SOLVED] Input/output error: grub-install mistake or faulty BIOS?

good evening people of the arch
i already managed to install this distro various times at this point, but i'm by no means an expert yet. sometimes what works on one machine does not on another (or a real one in the case of vbox)
while installing it on my mother's laptop tonight the grub-install command that always worked before spat out a really concerning error

#grub-install
Installing for x86_64-efi platform.
Could not prepare Boot variable: Input/output error
grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

i used no arguments as i had mounted the esp to /mnt/boot/efi.
i admit this is partly my fault, as i shouldn't have touched the already existing boot partition, but that's already gone now.

Last edited by kronyx (2024-05-02 20:10:36)

Offline

#2 2024-05-02 04:53:08

kronyx
Member
Registered: 2024-04-23
Posts: 14

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

additional information
when it boots (from the iso) the following appears before anything else:

[         0.113656] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.OSC.CDW1],
 AE_NOT_FOUND (20230628/psargs-330)
[         0.113705] ACPI Error: Aborting method \_SB._OSC due to previous error (AE_N
 OT_FOUND) (20230628/psparse-529)

(tried my best to copy it verbatim i hope it's accurate)

i remember that the same error message also appeared before in the previous installation (debian, also installed by me).
this is obviously Not Good, but i have little idea of what it means and even less of how to fix it
so any help would be greatly appreciated

Last edited by kronyx (2024-05-02 04:55:40)

Offline

#3 2024-05-02 10:58:00

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,118

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

The ACPI errors are most likely benign don't worry about those.

Which mainboard is this? failing to register the boot entry either means your UEFI has a weird implementation, or you might not actually booting the stick in UEFI mode or secure boot is active or... What output do you get from

efibootmgr -uv
fdisk -l
cat /sys/firmware/efi/fw_platform_size

Offline

#4 2024-05-02 14:54:01

kronyx
Member
Registered: 2024-04-23
Posts: 14

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

V1del wrote:

The ACPI errors are most likely benign don't worry about those.

Which mainboard is this? failing to register the boot entry either means your UEFI has a weird implementation, or you might not actually booting the stick in UEFI mode or secure boot is active or... What output do you get from

efibootmgr -uv
fdisk -l
cat /sys/firmware/efi/fw_platform_size
#efibootmgr -uv
BootCurrent: 0008
Timeout: 6 seconds
BootOrder: 0008,0005
Boot0005  UEFI: Built-in EFI Shell     VenMedia(5023bc-db26-429b-a648-bd47664c8012)
      dp: 04 03 14 00 5c b9 23 50 26 db 9b 42 a6 48 bd 47 66 4c 80 12 / 7f ff 04 00
    data: 00 00 42 4f
Boot0008* UEFI: MATSHITADVD-RAM UJ8G2   PciRoot(0x0)/Pci (0x13,0x0)/Sata(1,65535,0)/CDROM(1,0x75800,0x7800)
      dp: 02 01 0c 00 d0 41 03 0a 00 00 00 00 / 01 01 06 00 00 13 / 03 12 0a 00 01 00 ff ff 00 00 / 04 02 18 00 01 00 00 00 00 58 07 00 00 00 00 00 00 78 00 00 00 00 00 00 / 7f ff 04 00
    data: 00 00 42 4f
#cat /sys/firmware/efi/fw_platform_size
64

copied it by hand, took a while, ill send the other ones shortly

Last edited by kronyx (2024-05-02 14:56:12)

Offline

#5 2024-05-02 15:25:25

kronyx
Member
Registered: 2024-04-23
Posts: 14

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

#fdisk -l
Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: WDC WD5000LPCX-2
UNITS: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk Identifier: DAE43019-CFEE-4008-8A84-96786CFB9CBD

Device       Start       End   Sectors   Size Type
/dev/sda1     2048   1026047   1024000   500M EFI System
/dev/sda2  1026048   9414655   8388608     4G Linux swap
/dev/sda3  9414656 976773119 967358565 461.3G Linux root (x86-64)


Disk /dev/loop0: 788.23 MiB, 826523648 bytes, 1614304 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

secure boot is disabled
it simply refuses to boot from the dvd if it's enabled

Offline

#6 2024-05-02 15:42:07

kronyx
Member
Registered: 2024-04-23
Posts: 14

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

V1del wrote:

Which mainboard is this?

do you mean the motherboard?
i'm actually pretty sure it's a bootleg of some sort tbh

#cat /sys/devices/virtual/dmi/id/board_{vendor,name,version}
Digiboard
F40-30
To be filled by O.E.M.

Offline

#7 2024-05-02 15:44:57

kronyx
Member
Registered: 2024-04-23
Posts: 14

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

also, should i run the commands while chrooted?
the ones i sent were performed outside /mnt

Offline

#8 2024-05-02 15:53:40

kronyx
Member
Registered: 2024-04-23
Posts: 14

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

also they're not mounted at the current moment, that's right
i turned it off and went to sleep last night

Offline

#9 2024-05-02 16:43:24

kronyx
Member
Registered: 2024-04-23
Posts: 14

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

maybe going the archinstall route is the right answer here

Offline

#10 2024-05-02 17:07:21

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,118

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

This reads like you just have a shitty UEFI implementation that can't save NVRAM entries.

use --removable with grub-install, i.e.

grub-install --target=x86_64-efi --efi-directory=/boot/efi--bootloader-id=GRUB --removable

Offline

#11 2024-05-02 20:10:05

kronyx
Member
Registered: 2024-04-23
Posts: 14

Re: [SOLVED] Input/output error: grub-install mistake or faulty BIOS?

V1del wrote:

This reads like you just have a shitty UEFI implementation that can't save NVRAM entries.

use --removable with grub-install, i.e.

grub-install --target=x86_64-efi --efi-directory=/boot/efi--bootloader-id=GRUB --removable

ooohh thank you so much

but i'll have to tell the truth here, due to other circumstances i found it more worth it to disassemble the laptop for spare parts but i still appreciate the tip
i didn't know some UEFI implementations were like that

Offline

Board footer

Powered by FluxBB