You are not logged in.

#1 2007-02-07 20:48:25

From: Toronto, Canada
Registered: 2006-08-28
Posts: 43

Sporadic detection of internal madwifi card

Hey all,

I have been trying to get my atheros chipset internal wifi card in my Acer Travelmate 2510 notebook working. The problem is that only once in a while does it detect on boot. Sometimes when I boot wifi0 and ath0 exist, and it works perfectly. Other times, neither wifi0 or ath0 appear on boot, and nothing I try makes them appear. I check lsmod and all the proper modules are loaded, I am really confused why it wont detect sometimes.

One the times that it doesn't detect I have checked dmesg, and there has been info about the ath0 interface, and a message about the driver tainting the kernel (if that matters). There is a button on the front of the laptop that, when windows was on it when it came stock, enabled/disabled the wireless card. This button doesn't seem to do anything (produces no messages in dmesg, but when X is started produces an unknown-keycode error). The light behind the button is lit though.

I have tried hard reseting and properly shutting down to see if that makes a difference in detection on the next boot. I have tried both beyond and normal kernels, and both the -fallback images to see if its a driver problem, but it doesn't seem to make a difference.

Any ideas?



Board footer

Powered by FluxBB