You are not logged in.

#1 2024-06-24 19:32:50

chrisco23
Member
Registered: 2017-12-13
Posts: 132

[SOLVED] Steam doesn't launch with Sway / Wayland

I'm not a gamer but I have run Steam in the past and wanted to run it again.  Can't remember if I had it working since I moved from i3/X to sway/Wayland.

Spent many hours scouring forums but out of ideas.

My setup:

OS: Arch Linux x86_64
Host: XPS 15 9520
Kernel: Linux 6.9.6-arch1-1
Uptime: 40 mins
Packages: 1391 (pacman)
Shell: fish 3.7.1
Display (G246HL): 1920x1080 @ 60Hz
Display (INSIGNIA-TV): 3840x2160 @ 60Hz
WM: Sway (Wayland)
Cursor: Adwaita
Terminal: foot 1.17.2
Terminal Font: monospace (16pt)
CPU: 12th Gen Intel(R) Core(TM) i7-12700H (20) @ 4.70 GHz
GPU: Intel Iris Xe Graphics @ 1.40 GHz [Integrated]

Nvidia packages:

local/lib32-nvidia-utils 550.90.07-1
local/nvidia-dkms 550.90.07-3
local/nvidia-settings 550.78-1
local/nvidia-utils 550.90.07-3

This just hangs, no Steam window launched:

linuxuser@xps9520 ~> steam
steam.sh[39630]: Running Steam on arch rolling 64-bit
steam.sh[39630]: STEAM_RUNTIME is enabled automatically
setup.sh[39703]: Steam runtime environment up-to-date!
/home/linuxuser/.local/share/Steam/ubuntu12_32/steam-runtime/run.sh: line 85: steam-runtime-identify-library-abi: command not found
run.sh[39715]: steam-runtime-identify-library-abi --ldconfig-paths failed, falling back to ldconfig
steam.sh[39630]: Can't find 'steam-runtime-check-requirements', continuing anyway
tid(39746) burning pthread_key_t == 0 so we never use it
[2024-06-24 12:30:08] Startup - updater built Jan 13 2024 00:51:43
[2024-06-24 12:30:08] Startup - Steam Client launched with: '/home/fugbert/.local/share/Steam/ubuntu12_32/steam'
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
06/24 12:30:08 Init: Installing breakpad exception handler for appid(steam)/version(0)/tid(39746)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

Last edited by chrisco23 (2024-06-25 17:30:06)

Offline

#2 2024-06-25 07:41:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,326

Re: [SOLVED] Steam doesn't launch with Sway / Wayland

xorg-xwayland installed? Fullfilled all of the preconds mentioned in https://wiki.archlinux.org/title/Steam#Installation fullfilled? In particular the bit about generating an en_US.UTF8 locale?

Offline

#3 2024-06-25 17:34:39

chrisco23
Member
Registered: 2017-12-13
Posts: 132

Re: [SOLVED] Steam doesn't launch with Sway / Wayland

Thanks V1del, and yes I had done all those things, except the resolv.conf so I did that too now.

What did apparently work for me is running the flatpak version.  At least after playing one game for ten seconds.

I hadn't tried that because I've lived my life without flatpak and it does not seem like the "proper" way to me, especially since the non-flatpak way always worked for me before (again that may have been pre-Wayland not 100% sure).

So I've marked solved, because at least it runs, but the original problem stands.

Offline

Board footer

Powered by FluxBB