You are not logged in.

#1 2024-06-25 00:27:01

TheGameMaker
Member
Registered: 2024-06-20
Posts: 2

[SOLVED] After update 6/23 Getting black screen with mouse.

I updated before going to bed last night and shut down the machine, when I got home from work today I booted up and was give a blank black screen with a mouse pointer.

When I CTRL+ATL+F3 I’m given a terminal

Arch Linux 6.9.6-arch1-1 (tty3)

archlinux login:




I’m able to navigate around using the terminal but I’m unable to get a desktop to display. I searched around the internet and found that it might have something to do with:

libdisplay-info

so I downgraded from 0.2.0-1 ->  0.1.1-3 and this didn’t seem to fix my problem.

I even went as far as using Timeshift to go back to before the update, but it’s still not bringing up SDDM. I tried reinstalling SDDM and it still wont work.

Does anyone happen to have any advice on where to look further?


Something to note, I used the built in KDM Plasma tool to switch SDDM themes before doing the update but never rebooted the PC prior to updating.

(EDIT) I also tried to Run 6.6.35-2-lts Kernel and run into the same problem.

PC Specs:
7950x3d
7900XTX
Wayland
KDE Plasma 6.1

Any help or guidance is greatly appreciated.

Thank you!

Last edited by TheGameMaker (2024-06-25 13:11:54)

Offline

#2 2024-06-25 03:23:23

TheGameMaker
Member
Registered: 2024-06-20
Posts: 2

Re: [SOLVED] After update 6/23 Getting black screen with mouse.

Upon further troubleshooting, I found that qt5-wayland wasn’t installed for some reason. After installation everything seems to be working great. Marking as SOLVED.

Offline

Board footer

Powered by FluxBB