You are not logged in.

#1 2024-06-29 17:00:37

aframer
Member
Registered: 2024-06-29
Posts: 1

Black screen with "_" after install nvidia proprietary driver.

Hello everyone!

After GRUB menu and entering password for encrypted partition (LUKS) I getting this: https://i.imgur.com/Z52jFtQ.jpeg
I already tried everything, but no one solution didn't work for me. Btw with nouveau driver and archinstall everything works fine.

My installation script:
lsblk
cfdisk /dev/sda
mkfs.vfat /dev/sda1
mkfs.ext4 /dev/sda2
cryptsetup luksFormat /dev/sda3
cryptsetup open /dev/sda3 lvm
pvcreate /dev/mapper/lvm
vgcreate volgroup0 /dev/mapper/lvm
lvcreate -L 4GB volgroup0 -n lv_swap
lvcreate -L 30GB volgroup0 -n lv_root
lvcreate -l 100%FREE volgroup0 -n lv_home
mkswap /dev/volgroup0/lv_swap
mkfs.ext4 /dev/volgroup0/lv_root
mkfs.ext4 /dev/volgroup0/lv_home
swapon /dev/volgroup0/lv_swap
mount /dev/volgroup0/lv_root /mnt
mkdir /mnt/home
mount /dev/volgroup0/lv_home /mnt/home
mkdir /mnt/boot
mount /dev/sda2 /mnt/boot
pacstrap -K /mnt base
genfstab /mnt >> /mnt/etc/fstab
arch-chroot /mnt
pacman -S linux grub efibootmgr lvm2 sudo nano vim
pacman -S gnome gnome-tweaks networkmanager
pacman -S nvidia nvidia-utils nvidia-lts
passwd
useradd -m -G wheel user
passwd user
visudo
nano /etc/mkinitcpio.conf
(block ecnrypt lvm2 filesystem)
mkinitcpio -P
nano /etc/locale.gen
locale-gen
nano /etc/default/grub
(loglevel=3 cryptdevice=/dev/sda3:volgroup0 quiet)
mkdir /boot/EFI
mount /dev/sda1 /boot/EFI
grub-install --target=x86_64-efi --bootloader-id=GRUB
grub-mkconfig -o /boot/grub/grub.cfg
systemctl enable gdm
systemctl enable NetworkManager
exit
umount -a

Offline

#2 2024-06-29 17:05:59

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,775

Re: Black screen with "_" after install nvidia proprietary driver.

Offline

Board footer

Powered by FluxBB