You are not logged in.

#1 2007-02-14 15:18:51

otti
Member
Registered: 2006-12-18
Posts: 64

prevent module ipw2100 from being loaded on boot [Solved]

Hi,

on boot I get the following messages:

...
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, git-1.2.2
ipw2100: Copyright(c) 2003-2006 Intel Corporation
ACPI: PCI Interrupt Link [LNKE] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:02:04.0[A] -> Link [LNKE] -> GSI 11 (level, low) -> IRQ 11
ipw2100: Detected Intel PRO/Wireless 2100 Network Connection
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00c09f0000100dd5]
ipw2100: eth1: Firmware 'ipw2100-1.3.fw' not available or load failed.
ipw2100: eth1: ipw2100_get_firmware failed: -2
ipw2100: eth1: Failed to power on the adapter.
ipw2100: eth1: Failed to start the firmware.
ipw2100Error calling register_netdev.
ACPI: PCI interrupt for device 0000:02:04.0 disabled
ipw2100: probe of 0000:02:04.0 failed with error -5
...

But when I unload and again load ipw2100, after I logged in, wlan is working.
Stange thing is that I put the modules in MOD_BLACKLIST in rc.conf:

...
MOD_BLACKLIST=(pcspkr ipw2100 ieee80211 ieee80211_crypt)
...

Nevertheless the modules are loaded on boot (if my interpretation of the output is right...).

So my actual question is: How can I disable the loading of ipw2100 on boot?

Thanks for any help.

Last edited by otti (2007-02-19 17:33:57)

Offline

#2 2007-02-14 15:58:55

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: prevent module ipw2100 from being loaded on boot [Solved]

Sorry but you get a firmware error... Did you install the firmware? hmm


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#3 2007-02-14 22:34:57

otti
Member
Registered: 2006-12-18
Posts: 64

Re: prevent module ipw2100 from being loaded on boot [Solved]

Of course I have the firmware installed, how should wlan work without it? Oo
pacman -Qi ipw2100-fw:

Name           : ipw2100-fw
Version        : 1.3-1
Groups         : None
Packager       : Tobias Powalowski <tpowa@archlinux.org>
URL            : http://ipw2100.sourceforge.net/
License        : None
Architecture   : i686
Size           : 618994
Build Date     : Sun Apr  9 08:28:11 2006 UTC
Install Date   : Wed Dec 20 14:13:20 2006 UTC
Install Script : Yes
Reason:        : explicitly installed
Provides       : None
Depends On     : wireless_tools 
Required By    : None
Conflicts With : None
Description    : Intel Centrino Drivers firmware for IPW2100

Offline

#4 2007-02-17 15:43:11

otti
Member
Registered: 2006-12-18
Posts: 64

Re: prevent module ipw2100 from being loaded on boot [Solved]

anyone?

Offline

#5 2007-02-18 12:17:28

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: prevent module ipw2100 from being loaded on boot [Solved]

Yes

ipw2100: eth1: Firmware 'ipw2100-1.3.fw' not available or load failed.
ipw2100: eth1: ipw2100_get_firmware failed: -2

This looks very much like an error to me though?

Is the firmware located in /lib/firmware?


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#6 2007-02-18 15:08:50

otti
Member
Registered: 2006-12-18
Posts: 64

Re: prevent module ipw2100 from being loaded on boot [Solved]

Yes firmware is there:

ls /lib/firmware/

total 632K
drwxr-xr-x 2 root root 4.0K 2006-12-20 15:13 .
drwxr-xr-x 7 root root 4.0K 2007-02-16 16:20 ..
-rw-r--r-- 1 root root  12K 2006-04-09 10:28 LICENSE.ipw2100-fw
-rw-r--r-- 1 root root 197K 2006-04-09 10:28 ipw2100-1.3-i.fw
-rw-r--r-- 1 root root 192K 2006-04-09 10:28 ipw2100-1.3-p.fw
-rw-r--r-- 1 root root 205K 2006-04-09 10:28 ipw2100-1.3.fw

Is it possible to disable the loading of ipw2100 on bootup?

Offline

#7 2007-02-19 17:33:33

otti
Member
Registered: 2006-12-18
Posts: 64

Re: prevent module ipw2100 from being loaded on boot [Solved]

Omg, I found out why the module ipw2100 was loaded on bootup:
it was in my mkinitcpio.conf roll ...

Offline

Board footer

Powered by FluxBB