You are not logged in.

#1 2007-02-16 19:14:36

alexmat
Member
Registered: 2004-12-31
Posts: 100

Solved: modprobe kvm-intel

any idea why I'm getting this?

$> modprobe kvm-intel
FATAL: Error inserting kvm_intel (/lib/modules/2.6.20-ARCH/kernel/drivers/kvm/kvm-intel.ko): Operation not supported

Last edited by alexmat (2007-02-16 19:24:19)

Offline

#2 2007-02-16 19:25:42

alexmat
Member
Registered: 2004-12-31
Posts: 100

Re: Solved: modprobe kvm-intel

Doh, my cpu does not support kvm, a little searching on google turned this up:

To make absolutely sure your cpu will support kvm try this command.
$> egrep '^flags.*(vmx|svm)' /proc/cpuinfo

If you don't get some output from this command your cpu does not support kvm. If you get some output it might, see posts below.

Last edited by alexmat (2007-02-16 20:51:58)

Offline

#3 2007-02-16 19:33:13

zeus
Member
From: Korolev / Russia
Registered: 2006-09-19
Posts: 117
Website

Re: Solved: modprobe kvm-intel

try modprobe kvm

Offline

#4 2007-02-16 19:34:45

zeus
Member
From: Korolev / Russia
Registered: 2006-09-19
Posts: 117
Website

Re: Solved: modprobe kvm-intel

alexmat wrote:

Doh, my cpu does not support kvm, a little searching on google turned this up:

To make absolutely sure your cpu will support kvm try this command.
$> egrep '^flags.*(vmx|svm)' /proc/cpuinfo

If you don't get some output from this command your cpu does not support kvm. If you get some output it does.

[zeus@gefest ~]$ egrep '^flags.*(vmx|svm)' /proc/cpuinfo
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
[zeus@gefest ~]$ sudo modprobe kvm-intel
FATAL: Error inserting kvm_intel (/lib/modules/2.6.20-ARCH/kernel/drivers/kvm/kvm-intel.ko): Operation not supported
[zeus@gefest ~]$ sudo modprobe kvm
[zeus@gefest ~]$

Offline

#5 2007-02-16 19:40:32

alexmat
Member
Registered: 2004-12-31
Posts: 100

Re: Solved: modprobe kvm-intel

try this:
dmesg | grep kvm

I got back:
kvm: no hardware support

for more info, I am following this thread: http://ubuntuforums.org/showthread.php?t=350691

There was someone who mentioned that KVM cpu support might be enabled/disabled in BIOS depending on your system.

Last edited by alexmat (2007-02-16 19:43:04)

Offline

#6 2007-02-16 19:50:26

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,779

Re: Solved: modprobe kvm-intel

how come you can modprobe kvm even when your cpu does not support it ?????? like mine


Mr Green

Offline

#7 2007-02-17 03:13:58

damjan
Member
Registered: 2006-05-30
Posts: 351

Re: Solved: modprobe kvm-intel

@Mr Green
the 'kvm' module is just the generic support, then you need kvm-intel or kvm-amd to actully drive it.

Offline

#8 2007-02-17 10:24:06

billy
Member
From: Slovenia
Registered: 2006-09-13
Posts: 164

Re: Solved: modprobe kvm-intel

alexmat wrote:

There was someone who mentioned that KVM cpu support might be enabled/disabled in BIOS depending on your system.

yes. in BIOS you must enable intel virtualization technology (i don't know for amd processors) to be able to use kvm. i heard that there are also systems with processors suporting IVT but the BIOS doesn't support it so you can't use it neutral.

Offline

#9 2007-02-17 14:28:12

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,779

Re: Solved: modprobe kvm-intel

@damjam thanks man ;-)


Mr Green

Offline

#10 2007-02-19 04:50:13

damjan
Member
Registered: 2006-05-30
Posts: 351

Re: Solved: modprobe kvm-intel

billy wrote:

yes. in BIOS you must enable intel virtualization technology (i don't know for amd processors) to be able to use kvm. i heard that there are also systems with processors suporting IVT but the BIOS doesn't support it so you can't use it neutral.

From what I've heard, AMD does NOT allow disableing virtualization on their CPUs. Unlike Intel.

For example, the x60s Thinkpad, didn't have VT support even if the CPU supports it. Only with the latest BIOS release it's possible to enable it (i.e. you are allowed to use it). Other companies might not provide BIOSes that enable VT (Sony seems to be reported to do that).

Offline

#11 2008-05-28 18:01:11

cookiecaper
Member
Registered: 2007-09-22
Posts: 196

Re: Solved: modprobe kvm-intel

Virtualization is enabled in my BIOS. However, when I try to modprobe kvm-intel, I get [jeff@arch ~]$ sudo modprobe kvm-intel
FATAL: Error inserting kvm_intel (/lib/modules/2.6.25-ARCH/kernel/arch/x86/kvm/kvm-intel.ko): Operation not supported

and dmesg says kvm: disabled by bios, despite that fact that BIOS says, enabled.

Using Arch64 and EVGA 122-CK-NF68 (nForce 680i SLI) with BIOS version P29 (which I had to downgrade to to get my Xonar DX to function in Windows). Anyone know if this is a BIOS bug or a KVM bug?

Offline

#12 2008-07-16 08:03:42

cookiecaper
Member
Registered: 2007-09-22
Posts: 196

Re: Solved: modprobe kvm-intel

KVM works now with an up-to-date installation. Still don't know what exactly the problem was, but shouldn't be a worry after a system upgrade. Thanks all.

EDIT: It's two years later and for the record I'm running into this problem again. There is a policy against updating old threads so I will make a new one, I guess, but I don't want anyone who stumbles on this to think it's all done for.

Last edited by cookiecaper (2010-09-04 09:54:35)

Offline

Board footer

Powered by FluxBB