You are not logged in.

#1 2004-03-05 14:30:02

enigmabr
Member
From: Porto Alegre - Rio Grande do S
Registered: 2004-03-04
Posts: 13

no printer block device on /dev

Hi...

I can't print with any paralel port based print because don't exist anything block device on the /dev directory (no /dev/lp0 neither /dev/printers/0). I use 2.6.3 kernel that comes with the Arch Linux 0.6......


Any suggestions?

Thanks.

Offline

#2 2004-03-05 16:44:44

santo
Member
Registered: 2004-03-03
Posts: 11

Re: no printer block device on /dev

it should be /dev/parport0 instead of /dev/lp0

also make sure the following modules are loaded:

parport
  parport_pc
  ppdev

PS: I currently have a problem with the ppdev module:
it's not available for my 2.6.3 kernel (it was there for my 2.4.25 kernel)
Maybe it works for you without the ppdev module, but for me it isn't  sad

Offline

#3 2004-03-05 17:02:18

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: no printer block device on /dev

Try the lp module instead of ppdev.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#4 2004-03-05 17:04:06

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: no printer block device on /dev

make sure your modules are loading then if that does not create any devices you may have to add instructions to your devfsd.conf


AKA uknowme

I am not your friend

Offline

#5 2004-03-05 17:44:14

santo
Member
Registered: 2004-03-03
Posts: 11

Re: no printer block device on /dev

for me, the lp module does not work:

/dev/parport0 -> no such device

although it is there:

# cat /proc/ioports
0000-001f : dma1
0020-0021 : pic1
0040-005f : timer
0060-006f : keyboard
0070-0077 : rtc
0080-008f : dma page reg
00a0-00a1 : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
02f8-02ff : serial
0376-0376 : ide1
0378-037a : parport0
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial
0cf8-0cff : PCI conf1
a400-a43f : 0000:00:1f.5
a800-a8ff : 0000:00:1f.5
b800-b8ff : 0000:02:0b.0
  b800-b8ff : 8139too
d000-d01f : 0000:00:1d.2
  d000-d01f : uhci_hcd
d400-d41f : 0000:00:1d.1
  d400-d41f : uhci_hcd
d800-d81f : 0000:00:1d.0
  d800-d81f : uhci_hcd
e800-e81f : 0000:00:1f.3
f000-f00f : 0000:00:1f.1
  f000-f007 : ide0
  f008-f00f : ide1

Offline

#6 2004-03-06 21:21:22

skeeter
Member
From: Woodstock, CT
Registered: 2003-02-01
Posts: 77

Re: no printer block device on /dev

Try putting in rc.conf both (lp & parport_pc), some chipsets (VIA) seem to require both. HTH


Skeeter

Rule #1:  There are NO RULES!

Offline

Board footer

Powered by FluxBB