You are not logged in.

#1 2007-03-22 12:29:27

Registered: 2007-03-21
Posts: 12

Dell latitude laptop 0.8 b2 installation > kernel panic

Hi all,

Im new to this forums (and to Archlinux too) so hello everybody!

Yesterday i tried to install arch 0.8 beta2 on a dell latitude laptop (p3 500, 512 ram), but i always got to an error followed shortly by a kernel panic.

Since the laptop doesnt have no cdrom/floppy, im using this method to install it from another distro.
I have tried grub and lilo, with and without noapic, nolapic, ide-legacy, earlymodules=piix, rootfstype=ext3 but to no avail.
I tried with the 7.2 release but i got another kernel panic (a different one i think).

This is the first error i see:

ERROR: Failed to parse block device name for '/dev/hda2'
ERROR: root fs cannot be detected. Try using the rootfstype= kernel parameter

And then after some more text and shortly afterwards the kernel panic message:

:: Initramfs Completed - control passing to kinit
IP-Config: no devices to configure
Waiting 0 s before mounting root device...
kinit: Cannot open root device dev(0,0)
kinit: init not found!
Kernel panic - not syncing: Attempted to kill init!

Please help!

EDIT: /dev/hda2 is my root partition

Last edited by feralert (2007-03-22 13:12:51)


#2 2007-03-22 21:47:26

From: Suomi, Finland
Registered: 2006-10-30
Posts: 837

Re: Dell latitude laptop 0.8 b2 installation > kernel panic

Well my dell latitude works, thats the good news. smile

I did get a kernel panick with the udev change so I had to rename hda to sda in fstab.


The latest kernel .20 seems to hang with acx module so I just use 6.19-beyond kernel and no problems.

So these are the 2 problems you might have and good luck fixing them smile


#3 2007-03-24 21:40:12

Registered: 2007-03-24
Posts: 2

Re: Dell latitude laptop 0.8 b2 installation > kernel panic

I stumbled into a similar problem. I just installed Archlinux 0.72 and followed the ArchWiki beginners Guide. The system booted nicely without having it updated. When I then issued

# pacman --sync --refresh --sysupgrade
# pacman -Syu

and repeated both command until no more packets were updated, I decided to reboot.

The last lines I read on screen are:

RAMDISK: Compresse image found at block o
Time: acpi_pm clocksource has been installed.
No filesystem could mount root, tried:

Kernel panic - not syncing: VFS: Unable to mout root fs on unknown-block (0,0)

My knowlegde is not good enough to have any clues.

By the way: installing Archlinux twice repeats the error, and mz other OS boots without any problems.



#4 2007-03-24 23:15:20

From: Latvia, Riga
Registered: 2005-10-18
Posts: 445

Re: Dell latitude laptop 0.8 b2 installation > kernel panic

It's because initrd image name has changed. Fix /boot/grub/menu.lst or reinstall arch using 0.8 iso

IRC: Stalwart @ FreeNode
Skype ID: thestalwart
WeeChat-devel nightly packages for i686


#5 2007-03-25 08:02:27

Registered: 2007-03-24
Posts: 2

Re: Dell latitude laptop 0.8 b2 installation > kernel panic

Well, to my knowledge ARch 0.8 ISO has not been released yet. How does Arch Linux normally handle kernel updates if you use GRUB as boot loader? Other distros like Fedora create an extra entry in the boot menu list. Is Arch supposed to do the same or expects Arch that the user patches the menu.lst all the times by himself?



Board footer

Powered by FluxBB