You are not logged in.

#1 2007-04-14 21:27:05

dante4d
Member
From: Czech Republic
Registered: 2007-04-14
Posts: 172

[SOLVED] ALSA - no sound - ASUS F3JC

Hi,

I installed ALSA on my laptop (ASUS F3JC) with arch, but I can't hear anything. I followed alsa wiki, steps I did:

1. pacmaned all necessary alsa packages
2. added my regular user to audio group
3. set volume and unmuted all channels
4. added alsa daemon to rc.conf
5. searched this forum

But still no sound yet... Tried various stuff with rebooting, playing with config and so... Didn't help. I get /dev/dsp device error when KDE starts. I searched for what does that means. I found some soulutions, but didn't work for me...

Here is some more info:

$ lsmod | grep ^snd
snd_seq_oss            29184  0 
snd_seq_midi_event      6528  1 snd_seq_oss
snd_seq                46672  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          6796  2 snd_seq_oss,snd_seq
snd_pcm_oss            39072  0 
snd_mixer_oss          14464  1 snd_pcm_oss
snd_hda_intel          16280  0 
snd_hda_codec         157440  1 snd_hda_intel
snd_pcm                68484  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              18820  2 snd_seq,snd_pcm
snd                    43492  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
snd_page_alloc          7816  2 snd_hda_intel,snd_pcm
$ ls /dev/snd
total 0
crw-rw---- 1 root audio 116,  0 Apr 14 04:49 controlC0
crw-rw---- 1 root audio 116, 24 Apr 14 04:49 pcmC0D0c
crw-rw---- 1 root audio 116, 16 Apr 14 04:49 pcmC0D0p
crw-rw---- 1 root audio 116, 17 Apr 14 04:49 pcmC0D1p
crw-rw---- 1 root audio 116,  1 Apr 14 04:49 seq
crw-rw---- 1 root audio 116, 33 Apr 14 04:49 timer

In rc.conf:

DAEMONS=(syslog-ng @network @ipw3945d dhcpd @hal @crond @alsa @gpm @samba)

Groups for dante4d user:

audio users

I you need to know more, tell me.

Any help appreciated...
dante4d

Last edited by dante4d (2007-04-16 01:45:23)

Offline

#2 2007-04-14 21:49:27

Desintegr
Member
From: Orléans - France
Registered: 2005-01-31
Posts: 20

Re: [SOLVED] ALSA - no sound - ASUS F3JC

Seen on Ubuntu-fr Wiki : http://doc.ubuntu-fr.org/materiel/chips … da_realtek

With F3JC laptops, you have to use « options snd-hda-intel model=uniwill-m31 » to get sound working.

You can also try a more recent Kernel, a 2.6.21-rc for example : http://www.archlinux.org/~tpowa/2.6.21/ or a more recent ALSA installation (1.0.14rc3)

Last edited by Desintegr (2007-04-14 21:52:44)

Offline

#3 2007-04-14 22:15:50

dante4d
Member
From: Czech Republic
Registered: 2007-04-14
Posts: 172

Re: [SOLVED] ALSA - no sound - ASUS F3JC

Perfect, thank you... Already listening to some cool youtube stuff smile

http://www.youtube.com/watch?v=1sJqROHxjDA

dante4d

Offline

Board footer

Powered by FluxBB