You are not logged in.

#1 2007-04-19 11:26:47

Registered: 2007-04-19
Posts: 2

Grub Error 21

I have been doing battle for hours with Arch and my system attempting to make it work, but nothing has.

I have tried doing a default install that wipes out the whole harddrive and does it own partitioning scheme, I tried to make it work along side of Windows, I have tried more things than I know how to count to.


Core 2 Duo e6600
Asus P5B-E
WD 250Gb IDE

Everything I have tried has left me without being able to boot my system because Grub doesn't think any devices aside from (fd0) exist. Not one thing has gotten me farther than the Error 21 I get during the Grub runlevel 1.5. Hopefully someone on here has some idea.


#2 2007-04-19 13:19:13

From: Canada
Registered: 2005-12-06
Posts: 1,570

Re: Grub Error 21

I've noticed over the years, being grub my preferred boot loader, that under certain circumstances it will not work.
In each, and every time this happened, installing lilo made it go.
Give it a try. You can always install grub if you find a way around the problem.



#3 2007-04-19 20:41:27

From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: Grub Error 21

what install disc are you using ? 0.7 ,0.8 , ftp ?
be sure to take your time & read the documentation on the screen while installing
is grub pointing at /dev/hdXY or /dev/sdXY
what is in your /etc/fstab /dev/hdXY or /dev/sdXY
what modules & hooks are enabled in /etc/mkinitcpio.conf
this here may be a good read for you … mkinitcpio


Board footer

Powered by FluxBB