You are not logged in.

#1 2007-04-24 13:00:37

Registered: 2007-03-26
Posts: 81

Persistent Kernel panic following base upgrade

So I'm giving Arch another go, but I ran into the same problem that stopped me last time:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I receive that message on the Arch (not GRUB) boot screen. My laptop booted normally until this morning when I ran:

# pacman -Sy
# pacman -Su

Pacman was updated, and once again I entered:

# pacman -Su

I was prompted about replacing three (seemingly) small apps, and I answered "Y" to each one. Then I allowed pacman to take care of 108MB of updates.

How can I fix this? I'm installing off an 0.7.2 disc, so should I download 0.8 and write this off as a bug on the previous release? Or is there a solution here?


#2 2007-04-24 14:14:30

From: Suomi, Finland
Registered: 2006-10-30
Posts: 837

Re: Persistent Kernel panic following base upgrade

Well you should definately install from 0.8.

I don't think that in Arch the old installers are supported anymore when new one is out so no bug report needed.

Having said that, I think the problem i had was either the ata_piix or device name change, all i had to do to fix the kernel panick was:

In GRUB rename hda...hda3 and so on to sda...sda3 etc. also adding some kernel parameters like acpi=off etc might help.

If not install from latest 0.8 installer. (there migh be 1-3 problems between 7.2 and 8 versions anyway ^^)


#3 2007-05-25 11:41:24

Registered: 2007-05-25
Posts: 13

Re: Persistent Kernel panic following base upgrade

that is not the problem, you have to change the name of the .img file in menu.lst (I did it minutes ago and now it's working)
read this: … mmick.html


Board footer

Powered by FluxBB