You are not logged in.

#1 2007-04-24 16:04:36

From: Sun City, CA (native German)
Registered: 2007-04-06
Posts: 210

[Lan / Wlan Problem] Laptop Toshiba SatteliteA135-S2276

I am new to Arch Linux and still learning. My Linux Experiances are from Suse 8.3, Mandrake 7.0. Debian Sarge to now Arch Linux. Dave Crouse the owner from invited me Arch Linux. On my desktops I am very happy with Arch Linux now.
Now I like to get my Laptop run with Arch!
The Installation so far is done with Desktop GUI KDE! There are only some small problem left. The No. 1 is with my network.

Laptop Toshiba Satellite A135-S2276
Details Changes HD RPM 7200 80GB and 2GB PC 4200 Memorie
I am using Atheros WLan with the Wlan driver madwifi and the madwifi-util 0.9.3-1

My problem is, everytime when I change from "Wlan to Lan" or from "Lan to Wlan" I must reboot the computer for get it work.
When I plug in my network cable to the lan port and turn off the Wlan I must reboot to get Lan working. Same is when I unplug my network cable from the ethernet card and turn on my Wlan card I must reboot for get Wlan working. When I boot up with out going over the router and direct in to cabele modem and my cable modem is turned off, but then turn it on later, I can't get any internet until I reboot the Laptop. The network status applet show it is connected on eth0.

/etc/rc.d/network restart

what do I missing?

Last edited by JaDa (2007-04-25 14:57:37)

Arch Linux


#2 2007-08-19 11:38:13

From: NRW // Germany
Registered: 2007-07-06
Posts: 21

Re: [Lan / Wlan Problem] Laptop Toshiba SatteliteA135-S2276

Hey i got the same problem with my MSI-1719 Laptop. I seems the wlan-driver is dominant or something like that.

Edit: i got the problem solved with some help

You need to create some network-profiles from wich you can choose the settings for your network.
So you can switch from eth0 to wlan0 on the fly. Pretty handy

/etc/rc.conf  (WARNING: this are just the changings, not the whole rc.conf)

#!eth0="eth0 netmask broadcast"
INTERFACES=(lo !eth0 !wlan0)

#gateway="default gw"

# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
# Network profiles are found in /etc/network-profiles
NET_PROFILES=(!menu eth0 !eth0-dhcp !wlan0-dhcp)

and now add the profiles in /etc/network-profiles


# Network Profile

DESCRIPTION="eth0 dhcp"

# Network Settings

# Interface Settings (use IFOPTS="dhcp" for DHCP)

for example.
or for static ip you change the IFOPT="dhcp" to

IFOPTS=" netmask broadcast"

shure you can do the same for wlan0

to change the network just edit the /etc/rc.conf and just move the "!" from eth0 to wlan0 in line "NET_PROFILES" and restart the network with

(sudo) /etc/rc.d/network restart

Last edited by X-Tream (2007-08-19 12:37:16)


Board footer

Powered by FluxBB