You are not logged in.

#1 2007-05-08 16:32:49

Branta
Member
Registered: 2007-05-05
Posts: 36

Unable to detect wireless interface

Dell Latitude C400 with D-Link DWL-G650 pcmcia card

KDE Control Center-->Internet & Networks-->Administrator reports, Unable to detect wireless interface.

Installed AL 0.8 with pcmcia support.

Card works on many other distro's of Linux.  Have used ndiswrapper to install Windows driver on Linux distro's that didn't have a driver in kernel. 

lspci return is:

00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82830 CGC [Chipset Graphics Controller] (rev 04)
00:02.1 Display controller: Intel Corporation 82830 CGC [Chipset Graphics Controller]
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #1) (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio Controller (rev 02)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 02)
02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
02:01.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
03:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

03:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)is the D-Link pcmcia card.

lshw isn't  recognized and pacman --sync lshw not found in sync db.

iwconfig

lo        no wireless extensions.
eth0      no wireless extensions.

ifconfig

eth0    Link encap:Ethernet  HWaddr 00:08:74:21:69:E6
          inet addr:192.168.1.235  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::208:74ff:fe21:69e6/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1253 errors:0 dropped:0 overruns:0 frame:0
          TX packets:553 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:231984 (226.5 Kb)  TX bytes:132670 (129.5 Kb)
          Interrupt:11 Base address:0x4c00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:600 (600.0 b)  TX bytes:600 (600.0 b)

So what do I do to get my DWL-G650 to be detected?

--- Bob ---

Offline

#2 2007-05-08 21:41:54

byte
Member
From: Düsseldorf (DE)
Registered: 2006-05-01
Posts: 2,045

Re: Unable to detect wireless interface

Atheros card -> madwifi package


1000

Offline

#3 2007-05-08 21:58:08

Branta
Member
Registered: 2007-05-05
Posts: 36

Re: Unable to detect wireless interface

I have tried madwifi but it also does not work because:

The wireless card is not detected.

What do I do to cause the working wwireless pcmcia card to be detected?

TIA,

--- Bob ---

Offline

#4 2007-05-08 22:57:08

ravster
Member
From: Queen's U, Kingston, Canada
Registered: 2004-05-02
Posts: 285
Website

Re: Unable to detect wireless interface

Branta wrote:

lshw isn't  recognized and pacman --sync lshw not found in sync db.

Do you mean lshwd?

Offline

#5 2007-05-09 04:25:47

Branta
Member
Registered: 2007-05-05
Posts: 36

Re: Unable to detect wireless interface

Thank your for the correction!

lshwd
00:00.0 Host bridge: Intel Corp.|82830 Host-Hub I/F Bridge SDRAM Controller (intel-agp)
00:02.0 VGA compatible controller: Intel Corp.|82830 CGC Integrated Graphics Device (i810)
00:02.1 Display controller: Intel Corp.|82830 CGC Integrated Graphics Device (i810)
00:1d.0 USB Controller: Intel Corp.|82801 USB Controller (uhci_hcd)
00:1e.0 PCI bridge: Intel Corp.|82801 Hub Interface to PCI Bridge (hw_random)
00:1f.0 ISA bridge: Intel Corp.|82801 LPC Interface (i810-tco)
00:1f.1 IDE interface: Intel Corp.|82801 UltraATA IDE Controller (piix)
00:1f.5 Multimedia audio controller: Intel Corp.|82801 AC97 Audio Controller (i810_audio)
00:1f.6 Modem: Intel Corp.|PCTEL 2304 WT V.92 MDC Modem (slamr)
02:00.0 Ethernet controller: 3Com Corp.|3c905C-TX [Fast Etherlink] (3c59x)
02:01.0 CardBus bridge: Texas Instruments|PCI1410 PC card Cardbus Controller (yenta_socket)
03:00.0 Ethernet controller: Atheros Communications Inc.|AR5213 802.11a/b/g Wireless Adapter (ath_pci)
001:002 USB Human Interface Devices: USB Optical Mouse [/dev/input/mice] (usbhid)
001:001 USB Hub: Virtual|Hub (hub)

This is the pcmcia wireless card:
03:00.0 Ethernet controller: Atheros Communications Inc.|AR5213 802.11a/b/g Wireless Adapter (ath_pci)



KDE Control Center-->Internet & Networks-->Administrator reports, Unable to detect wireless interface.



What should I do?


--- Bob ---




Still, as I say on the first post:  Unable to detect wireless interface

Offline

#6 2007-05-09 04:47:05

dmartins
Member
Registered: 2006-09-23
Posts: 316

Re: Unable to detect wireless interface

Have a look through the output from dmesg for anything related to the wireless card. Sometimes you can find a clue as to what name it has been given or some error which will give you an idea on where to go next.
Also, what is the output from ifconfig -a ?

Last edited by dmartins (2007-05-09 04:47:21)


-- Dan

Offline

#7 2007-05-09 06:44:26

Branta
Member
Registered: 2007-05-05
Posts: 36

Re: Unable to detect wireless interface

ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:08:74:21:69:E6
          inet addr:192.168.1.235  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::208:74ff:fe21:69e6/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:248 errors:0 dropped:0 overruns:0 frame:0
          TX packets:303 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:89601 (87.5 Kb)  TX bytes:80972 (79.0 Kb)
          Interrupt:11 Base address:0x4c00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:600 (600.0 b)  TX bytes:600 (600.0 b)

dmesg contained no listing of the wireless card or eth0 either.

The fundamental problem:  Unable to detect wireless interface.


--- Bob ---

Offline

#8 2007-05-09 13:14:38

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Unable to detect wireless interface

well, if you dont have the driver, it can't detect it!

The fundamental problem is not what the stupid KDE gui says.

Your ifconfig shows, that if you have installed the madwifi driver, it isnt being loaded.

pacman -S madwifi
and then
modprobe madwifi

James

Offline

#9 2007-05-09 16:26:48

Branta
Member
Registered: 2007-05-05
Posts: 36

Re: Unable to detect wireless interface

Everything from root.
pacman -S madwifi
It was up to date but I installed it again anyway.
modprobe madwifi

FATAL: Module madwifi not found.

http://wiki.archlinux.org/index.php/Wireless says ath_pci is the module for madwifi but when from root I do:

modprobe ath_pci countrycode=840

I get this error:

FATAL: Module ath_pci not found.

When I navigate to /lib/modules/2.6.21-ARCH/net and execute the line it likewise fails.
This likewise fails too:

modprobe /lib/modules/2.6.21-ARCH/net/ath_pci countrycode=840

Here is the directory for /lib/modules/2.6.21_ARCH/net:

ath_hal.ko        ath_rate_sample.ko  wlan_scan_ap.ko   wlan_xauth.ko
ath_pci.ko        wlan.ko             wlan_scan_sta.ko
ath_rate_amrr.ko  wlan_acl.ko         wlan_tkip.ko
ath_rate_onoe.ko  wlan_ccmp.ko        wlan_wep.ko

What should I do?

--- Bob ---

Offline

#10 2007-05-09 18:15:55

Branta
Member
Registered: 2007-05-05
Posts: 36

Re: Unable to detect wireless interface

I did this:

pacman -Sf kernel26

Now I get this when I do:

modprobe ath_pci countrycode=840
FATAL: Could not load /lib/modules/2.6.20-ARCH/modules.dep: No such file or directory

What's more, now there is no /lib/modules/2.6.20-ARCH
as the path is only, /lib/modules/2.6.21-ARCH


What must now do?


--- Bob ---

Offline

#11 2007-05-09 22:26:59

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Unable to detect wireless interface

pacman -Syu, you're running an old kernel.

James

Offline

#12 2007-05-10 00:09:18

Branta
Member
Registered: 2007-05-05
Posts: 36

Re: Unable to detect wireless interface

In my last post after I ran pacman -Sf kernel26 I DID NOT reboot.

After I booted the wireless worked and after I adjusted /etc/rc.conf and BOOTED I had wireless acess.

Thanks for the help.  You comment earlier unlocked the key.

How do I determine what kernel I am using and what do I do to upgrade  it?


Thanks Again,


--- Bob ---

Offline

#13 2007-05-10 00:29:06

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Unable to detect wireless interface

To find the kernel you are currently using:

uname -r

To find the currently installed kernel

pacman -Qi kernel26

a kernel upgrade requires a reboot, and if you use lilo, you need to run 'lilo' too.

James

Offline

Board footer

Powered by FluxBB