You are not logged in.

#1 2007-06-24 04:02:21

faw
Member
Registered: 2007-06-09
Posts: 18

[SOLVED] A) Xfce tips: how to stop, B) terminal font size: how to set.

Hi Archers,

Installed Arch with Xfce on my T43 Thinkpad about 6 weeks ago. Takes a bit more attention during the install process, but to be honest, this extra time is well worth the enjoyment of a system that is so simple that it just runs with little or no hassle so far. (Enjoyment - can you actually 'enjoy' an os/distro? Lol). Pacman is wonderful. And the AUR is great. Even _I_ have managed to build a few packages out of there (which is pretty impressive for me anyway smile ). Not as daunting as it first seems! Thanks goes out to all you Archers!

There is one thing that I haven't been able to work out yet. When I login in, the Xfce 'Tips & Tricks' window pops up. Now there is a box that you can tick to not show it at future login, but it keeps coming back at every startup like some ghost from the past.

I also want to change the font size in terminal, and I can change it for the length of my desktop session, but the next time I log back in it is back to the default size again. FYI, when logging out of Xfce I am ticking the save session box, and it is working as it reopens whatever programs that I had open when I shutdown.

So I was thinking: 
     Do I need to be added to a particular group to allow these settings to be updated? Currently I am a member of the following groups: wheel network video audio optical storage power users slocate abs.
     Or are the settings not 'sticking' due to incorrect permissions on the respective config files somewhere? (Where?)

Any ideas? It's probably something very simple that is staring me in the face, but right now I am at a loss.

Cheers,

Last edited by faw (2007-06-25 10:02:44)

Offline

#2 2007-06-24 05:49:01

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,545

Re: [SOLVED] A) Xfce tips: how to stop, B) terminal font size: how to set.

It does sound like bad permissions on config files. XFCE stores things in .config , .cache, and .local in your home directory.

Offline

#3 2007-06-24 12:09:44

faw
Member
Registered: 2007-06-09
Posts: 18

Re: [SOLVED] A) Xfce tips: how to stop, B) terminal font size: how to set.

OK, so after peeking through those directories and opening a few files to see what's inside, I found the files I needed to attack: ~/.config/Terminal/terminalrc and ~/.config/autostart/xfce4-tips-autostart.desktop

Both the directories and the files had root as the owner. Changing them so I was the owner fixed the problem. Actually, as soon as I changed terminalrc, the terminal resized to the setting I wanted. The setting was already correct in the file from me trying to change it at some point in the desktop, but as the owner of the file was root, the system couldn't access it. Weird. I thought that if the owner was root, the file couldn't have been changed from the desktop? It was the same with the xfce4-tips file as well. When I checked inside the files to work out which ones were which, I noticed that this also had already changed to the correct setting, it just couldn't be read by the system. Does anyone know why this would happen?

Well, I better not strain my little brain too hard. I am just glad I managed to fix it.

Thanks ataraxia for your help! big_smile

Offline

Board footer

Powered by FluxBB