You are not logged in.

#1 2007-07-17 19:19:44

amadlopes
Member
Registered: 2007-06-28
Posts: 35

Install deb or rpm package (SOLVED)

I'm using Arch for 5 or 6 weeks and i'm loving it, you've done a really good job specialy on the wiki and forum. I installed the distro and this is the first time i have to ask you something. Thanks for the great job.

I need to install some printer drivers but Brother only have it for deb or rpm distros how can i solve this problem. I already tryed deb2targz, but it fails to install (pacman -A *tar.gz).

[root@arch Desktop]# pacman -A mfc210clpr-1.0.2-1.i386.tar.gz
loading package data...
error: missing package metadata

error: failed to add target 'mfc210clpr-1.0.2-1.i386.tar.gz' (unexpected error)

Can anybody help me ? Is there anything that i'm doing wrong ?  Is there anything that i can do to install this ?


Thank you for your help.


Sorry for my bad english...

Last edited by amadlopes (2007-07-19 17:38:19)

Offline

#2 2007-07-17 19:27:22

Thrillhouse
Member
From: Arlington, VA, USA
Registered: 2007-05-29
Posts: 175

Re: Install deb or rpm package (SOLVED)

pacman needs .pkg.tar.gz files, not just .tar.gz.  I think you can use rpmextract for rpm's, not sure of an equivalent for deb but if all else fails, you can try using alien to convert from deb to rpm and then rpm extract.


For the strength of the pack is the wolf, and the strength of the wolf is the pack.

Offline

#3 2007-07-18 05:30:09

mucknert
Member
From: Berlin // Germany
Registered: 2006-06-27
Posts: 510

Re: Install deb or rpm package (SOLVED)

The tar.gz you have created wont install because it does not feature the Metadata that pacman needs (as Thrillhouse suggested). Although you can use that package to create a bundle that pacman can work with. Check the Wiki for Informations about PKGBUILDs and  makepkg. Time to get your hands dirty, it seems. smile


Todays mistakes are tomorrows catastrophes.

Offline

#4 2007-07-18 08:10:53

somairotevoli
Member
Registered: 2006-05-23
Posts: 335

Offline

#5 2007-07-18 12:50:33

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,172

Re: Install deb or rpm package (SOLVED)

They don't have a source tarball for download? Shame on them.

Offline

#6 2007-07-18 14:58:59

amadlopes
Member
Registered: 2007-06-28
Posts: 35

Re: Install deb or rpm package (SOLVED)

Ok.
'rpmextract' didn't work:

[root@arch Desktop]# rpmextract.sh mfc210clpr-1.0.2-1.i386.rpm
no package supplied
[root@arch Desktop]#

But 'deb2targz' worked. Now i have a problem. I used the wiki pages to try to install the drivers from Brother.
http://wiki.archlinux.org/index.php/Brother:HL-2040

So i extract the deb files to tar.gz using 'deb2targz' than uncompressed the files.
I replaced all init.d with rc.d. I copied the files to the respectived directory and than:

[root@arch Desktop]# cd /home/amadlopes/Desktop
[root@arch Desktop]# cd /usr/local/Brother/cupswrapper/
[root@arch cupswrapper]# ls
cupswrapperMFC210C-1.0.2  cupswrapperMFC210C-1.0.2~
[root@arch cupswrapper]# ./cupswrapperMFC210C-1.0.2
bash: ./cupswrapperMFC210C-1.0.2: /bin/csh: bad interpreter: No such file or directory
[root@arch cupswrapper]#

Can you help me ?

The file is this:


#! /bin/csh
#
# Brother Print filter
# Copyright (C) 2004 Brother. Industries, Ltd.

# This program is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by the Free
# Software Foundation; either version 2 of the License, or (at your option)
# any later version.
#
# This program is distributed in the hope that it will be useful, but WITHOUT
# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
# more details.
#
# You should have received a copy of the GNU General Public License along with
# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
# Place, Suite 330, Boston, MA  02111-1307  USA
#

...

Thank you

Offline

#7 2007-07-18 15:03:28

amadlopes
Member
Registered: 2007-06-28
Posts: 35

Re: Install deb or rpm package (SOLVED)

Misfit138 wrote:

They don't have a source tarball for download? Shame on them.

Yes shame on them...

But there are worst brands, those that don't have drivers at all. I already wrote an e.mail to them but i didn't have any answer.

Offline

#8 2007-07-19 17:45:38

amadlopes
Member
Registered: 2007-06-28
Posts: 35

Re: Install deb or rpm package (SOLVED)

Ok thank you all.
I solved the problem.

I just installed 'tcsh':

pacman -S tcsh

And then:

[root@arch cupswrapper]# which tcsh
/usr/bin/tcsh

And then edit cupswrapperMFC210C file:

#! /bin/csh
#
# Brother Print filter
# Copyright (C) 2004 Brother. Industries, Ltd

Change it to:

#! /usr/bin/tcsh
#
# Brother Print filter
# Copyright (C) 2004 Brother. Industries, Ltd

Thats all folks

Offline

Board footer

Powered by FluxBB