You are not logged in.

#1 2007-07-26 16:29:42

Registered: 2007-07-26
Posts: 2

[solved] Dell XPS M1710 Sound Card (snd-hda-intel) - Subwoofer problem


I own a XPS M1710 and I installed alsa as usually

pacman -S alsa-lib alsa-utils

and then


This laptop has an integrated subwoofer. Now with ALSA installed, the sound card is working but sound only comes out of left and right speakers. Subwoofer is not working at all. It works perfectly in Windows Vista, so, it's not a hardware problem.

I googled a lot and the only useful information I found was these two posts: (which is referenced in the first one)

I tried to solve my problem by adding the line

options snd-hda-intel model=ref

to my /etc/modprobe.d/sound right below (or above, it made no difference) of the ALSA-config autogenerated lines but I didn't get that LFE volume control that they talk about in the first post above.

I thought it wouldn't be necessary to reinstall ALSA since the version I have installed is

alsa-lib 1.0.14-3
alsa-plugins 1.0.14-2
alsa-utils 1.0.14-1

that seems to be newer than the one they use in the second post. Also, I would like to keep the ALSA version from Arch repositories since many packages (like xine, skype, wine, etc.) depend on it.

I have no clues now since that seems to be the only solution posted on the Internet that has worked for someone but it didn't for me.

Thank you very much for your help.


I tried installing alsa-driver, alsa-lib and alsa-utils from the ALSA's website sources. Nothing happened. I tried adding "options snd-hda-intel model=ref" and "options snd-hda-intel model=6stack-full" in my /etc/modprobe.conf but nothing different happenened.

I'm really clueless now. I can't get that subwoofer to work. Any ideas?

By adding option "index=0" additionally to the "model=ref" one, I finally got it working. I got the LFE control and my subwoofer works perfectly now. Hope this could help everyone with the same problem.

Last edited by hades646 (2007-08-17 00:26:51)


#2 2013-03-13 16:45:55

Registered: 2010-10-29
Posts: 2

Re: [solved] Dell XPS M1710 Sound Card (snd-hda-intel) - Subwoofer problem

Thanks a lot hades646

It worked on my Dell Inspiron 7720.
Adding to file:
options snd_hda_intel model=ref index=0

And setting in alsamixer Mono Mux to DAC1 :-)


Board footer

Powered by FluxBB