You are not logged in.

#1 2007-08-02 06:03:17

justin
Member
From: Philadelphia
Registered: 2007-04-18
Posts: 130

Locale problems

I am having trouble figuring out how to set up my locales. I had this working before, but I've since reinstalled Arch and can't remember how I did it. I use aterm, and If I have my locale in /etc/rc.conf set to "en_US" and the "en_US   ISO-8859-1" line uncommented in /etc/locale.gen, the characters in aterm are just fine:

char1.png

but when I open vlc, I get

vlc.png

If I uncomment both "en_US   ISO-8859-1" and "en_US.UTF-8    UTF-8" in /etc/locale.gen, vlc works, but aterms characters look like this:

char2.png

Any suggestions on getting both aterm and vlc to work?

Offline

#2 2007-08-02 11:22:35

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: Locale problems

as root run locale-gen

Offline

#3 2007-08-02 16:56:53

justin
Member
From: Philadelphia
Registered: 2007-04-18
Posts: 130

Re: Locale problems

I've done that after every change, but I still get the same problem.

Offline

#4 2007-08-02 17:06:56

thayer
Fellow
From: Vancouver, BC
Registered: 2007-05-20
Posts: 1,560
Website

Re: Locale problems

This probably won't help, but in my case I find that /etc/profile always sets LC_COLLATE to C, regardless of my rc.conf settings.  It messes up my file sort orders unless I comment the line out.  Perhaps there is something in your /etc/profile?


thayer williams ~ cinderwick.ca

Offline

#5 2007-08-03 23:49:58

justin
Member
From: Philadelphia
Registered: 2007-04-18
Posts: 130

Re: Locale problems

Fixed after a reboot, but not sure why. Does screen keep you from logging out 'completely'?

Offline

#6 2007-08-05 01:35:11

saciel
Member
From: Germany
Registered: 2006-07-30
Posts: 153

Re: Locale problems

Actually, before running locale-gen you have to uncomment the locales you would like to generate in '/etc/locale.gen'.


They say if you reverse play a Windows CD you can hear satanic verses... But wanna know what's even worse? If you forward play it, it's gonna install Windows on your system!

Offline

#7 2007-08-05 17:01:58

eldarion
Member
From: Santarém - Portugal
Registered: 2006-08-01
Posts: 71

Re: Locale problems

Have you changed the LOCALE line in /etc/rc.conf with LOCALE="en_US.UTF-8" ?

Offline

#8 2007-08-05 22:42:55

justin
Member
From: Philadelphia
Registered: 2007-04-18
Posts: 130

Re: Locale problems

Thanks for all your suggestions, but as I posted earlier, it's now fixed after a reboot. smile

Offline

Board footer

Powered by FluxBB