You are not logged in.

#1 2007-08-02 09:09:40

Registered: 2007-08-02
Posts: 111

Unable to boot after the installation.

First off all, I apologize if this has been answered somewhere. I've looked everywhere for the solution and I've had no luck so far. This is my first distribution that uses the 2.6 kernel. All the others I've used have been running 2.4 by default.

I'm planning to setup a small Arch Linux server on an old 533Mhz Celeron with 256MB RAM and two IDE HDDs. The master IDE is a 9GB HDD and the slave is 80GB HDD. All partitions I'm using are using ReiserFS (other then swap of course.)

I used the Duke Base install ISO (validated with the MD5SUM) to install the system. I want to keep the system as minimal as possible so I didn't install the entire base package set, however I'm certain that I didn't remove any package that was required to boot. There is nothing in the booting messages about missing programs.

I completed the installation fine. It's the restart and first boot that is the trouble.

This is the messages that is displayed before I'm put in the recovery shell...

:: Running Hook [filesystems]
:: Loading root filesystem modules...
Attempting to create root device '/dev/sda1'
ERROR: Failed to parse block device name for '/dev/sda1' unknown
ERROR: root fs cannot be detected. Try using the rootfstype= kernel parameter.
Waiting for devices to settle...done.

Root device '/dev/sda1' doesn't exist, attempting to create it
ERROR: Failed to parse block device name for '/dev/sda1'
ERROR: Unable to create/detect root device '/dev/sda1'
Dropping to a recovery shell... type 'exit' to reboot
NOTE: klibc contains no 'ls' binary, use 'echo *' instead

If the device '/dev/sda1' gets created while you are here,
try adding 'rootdelay=8' or higher to the kernel command-line

I've tried the default fallback kernel along with another with several other modules and hooks loaded, as well add adding rootfstype=reiserfs as suggested. Unfortunately nothing has worked.

I'll note that this is an entirely an PATA system without SATA support and the first distribution that lists my HDD as '/dev/sda' instead of '/dev/hda' by default. Doesn't seem to be a problem however, just the way the latest kernels work.

Huge thanks to anybody who can help me with this.

Last edited by Lazer (2007-08-02 09:10:46)


#2 2007-08-02 11:18:23

From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: Unable to boot after the installation.

welcome to arch

yes with arch if you use defaults on install concerning /etc/mkinitcpio.conf  hda=sda in arch
so if you could post /etc/lilo.conf-or-/boot/grub/menu.lst <whichever you use lilo or grub
also your /etc/fstab

your gonna need a way to boot into system so heres info on that … oot_loader


#3 2007-08-02 22:33:19

Registered: 2007-08-02
Posts: 111

Re: Unable to boot after the installation.

Thanks for your reply.

Here's the content of my /boot/grub/menu.lst without the default comments...

#general configuration:
timeout    5
default    0
color light-blue/black light-cyan/blue

# (0) Arch Linux
title    Arch Linux
root    (hd0,0)
kernel    /boot/vmlinuz26 root=/dev/sda1 ro
initrd    /boot/kernel26.img

# (1) Arch Linux
title    Arch Linux Fallback
root    (hd0,0)
kernel    /boot/vmlinuz26 root=/dev/sda1 ro
initrd    /boot/kernel26-fallback.img

...and here is fstab...

/dev/cdrom /mnt/cdrom    iso9660    ro,user,noauto,unhide    0    0
/dev/cdrom1 /mnt/cdrom1    iso9660    ro,user,noauto,unhide    0    0
/dev/dvd /mnt/dvd    udf    ro,user,noauto,unhide    0    0
/dev/fd0 /mnt/fd0    vfat    user,noauto    0    0
/dev/sda1 /    reiserfs    defaults    0    1
/dev/sda2 swap    swap    defaults    0    0

Last edited by Lazer (2007-08-02 22:33:54)


#4 2007-08-04 00:43:40

From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: Unable to boot after the installation.

menu.lst & fstab seem to be in order , what about /etc/mkinitcpio.conf what modules& hooks are you using?


#5 2007-08-04 06:05:56

Registered: 2007-08-02
Posts: 111

Re: Unable to boot after the installation.

Here's the content of /etc/mkinitcpio.conf (again without the default comments)...

MODULES="ata_generic ata_piix"
HOOKS="base udev autodetect pata scsi sata usbinput keymap filesystems"

It's the default as far as I know. I also tried too add resierfs to the modules list in the fallback kernel, however that made no difference.


#6 2007-08-04 11:36:24

From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: Unable to boot after the installation.

can you boot into your system with install cd?
at 1st prompt type

vmlinuz root=/dev/sda1

then hit enter
hopefully it will boot up into system
login as root then type

mkinitcpio -M

this will list modules needed to put into /etc/mkinitcpio.conf
not all are needed but just to be sure put them all in once into your system trial & error you can slim this down as to what is truely needed to boot
when done inserting modules run

mkinitcpio -g /boot/kernel26.img

this will generate/overwrite /boot/kernel26.image
remove cd
this should get you into your system


#7 2007-08-05 15:56:10

Registered: 2007-05-28
Posts: 17

Re: Unable to boot after the installation.

it seems that i have the same problem:

but i cant boot into my existing installation because my root -filesystem is on a logical volume. i start the install cd mount the harddisks and use chroot. i can write a new image but it doesn't find my harddisks.

edit: i solved the problem. see the link above.

Last edited by stonerl (2007-08-05 16:20:02)


#8 2007-08-05 19:07:47

From: /home/gazj -> /uk/cambs
Registered: 2007-02-09
Posts: 679

Re: Unable to boot after the installation.

i seem to remember having a similar problem, i think it needs ext3 (or any other file system) adding to modules then file systems taking from hooks, i always do this by default on a new install now.  Please see my mkinitcpio.conf attached.

# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES="pata_via ata_generic ext3"

# This setting includes, into the CPIO image, and additional
# binaries a given user may wish.  This is run first, so may
# be used to override the actual binaries used in a given hook.
# (Existing files are NOT overwritten is already added)
# BINARIES are dependancy parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in anyway.  This is useful for config files.
# Some users may wish to include modprobe.conf for custom module options,
# like so:
#    FILES="/etc/modprobe.conf"

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'modload' may be used in place of 'udev', but is not recommended
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
#    This setup specifies all modules in the MODULES setting above.
#    No raid, lvm2, or encrypted root is needed.
#    HOOKS="base"
#    This setup will autodetect all modules for your system and should
#    work as a sane default
#    HOOKS="base udev autodetect ide scsi sata filesystems"
#    This setup will generate a 'full' image which supports most systems.
#    No autodetection is done.
#    HOOKS="base udev ide scsi sata usb filesystems"
#    This setup assembles an ide raid array with an encrypted root FS.
#    Note: See 'mkinitcpio -H raid' for more information on raid devices.
#    HOOKS="base udev ide raid encrypt filesystems"
#    This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev usb lvm2 filesystems"
HOOKS="base udev autodetect pata"

It was a long time ago so i am not certain you are having the same problem i did, but it's worth a try.

Good Luck

Last edited by gazj (2007-08-05 19:08:32)


#9 2007-09-23 17:16:21

Registered: 2007-08-23
Posts: 90

Re: Unable to boot after the installation.

I currently have the same Problem but as I'm working on a Subnotebook, there isn't any CD/DVD-ROM or Floppy-Drive. I actually only have Win XP and Archlinux-BASE installed on it. Win works, Archlinux not.

Is there a way to repair my broken Archlinux (actually it's a fresh install from yesterday) by using Windows and without disassembling the Notebook to get access to the HDD?


Why are we here? What is the sense of life?


#10 2007-09-26 18:44:30

Forum Fellow
From: Manchester, UK
Registered: 2007-06-21
Posts: 1,899

Re: Unable to boot after the installation.

I'm having the same problem, but only after installing the kernel26viper from the Proaudio repo. The normal kernel26 and the fallback image work, but I get this error with the viper version. I have tried to change sda to hda, then I tried to add ext3 to the modules of mkinitcpio. I am not so experienced, so I don't know what else I could try. I have tried to ask this question in the Proaudio thread but I've been ignored, so I hope I can find an answer in this more general thread.
So, if the mkinitcpio.conf is working for the other kernels, why isn't it working for the viper one? Is the problem actually there? (I've also tried to reconfigure the kernel with the command "mkinitcpio -p kernel26viper", but had no success).

Thanks for your time.

Have you Syued today?
Free music for free people! | Earthlings

"Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away." -- A. de Saint-Exupery


Board footer

Powered by FluxBB