You are not logged in.

#1 2007-08-04 18:12:12

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

[SOLVED] can't build firefox - full perl install required

Hi Archers,

Here's the error message i get when i try to build Firefox :

checking for perl... /usr/bin/perl
checking for minimum required perl version >= 5.004... 5.008008
checking for full perl installation... no
configure: error: Cannot find Config.pm or $Config{archlib}.  A full perl installation is required.
*** Fix above errors and then restart with               "make -f client.mk build"
make[1]: *** [configure] Error 1
make[1]: Leaving directory `/home/eb/pkg/firefox/src/mozilla'
make: *** [/home/eb/pkg/firefox/src/mozilla/config.status] Error 2
==> ERROR: Build Failed.  Aborting...

Any ideas about what a full perl install should be ?

Thanks in advance.

Last edited by bangkok_manouel (2007-08-05 07:54:54)


All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

#2 2007-08-04 21:03:38

shen
Member
Registered: 2003-09-05
Posts: 272
Website

Re: [SOLVED] can't build firefox - full perl install required

Are you building it from abs and the stock PKGBUILD from the Arch repo? I have perl installed by default for openoffice so I didn't noticed if it was a build req but it's not listed as one in the arch PKGBUILD. I just removed perl and using the PKGBUILD from abs with not modification firefox will build just fine. So it may be how you are building it or something.

Offline

#3 2007-08-05 07:33:40

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

Re: [SOLVED] can't build firefox - full perl install required

Thanks for your reply. Well you're right, few more infos won't hurt...

I'm indeed using PKGBUILD from ABS. (no custom build)

Arch : i686
Dist : Testing (up2date)

[eb@blackout ~]$ pacman -Qi perl
Name           : perl
Version        : 5.8.8-5
URL            : http://www.perl.org
License        : None
Groups         : None
Provides       : None
Depends On     : glibc  coreutils  gdbm  db>=4.5  
Removes        : None
Required By    : automake  bogofilter  groff  inkscape  lm_sensors  perl-date-manip  perl-error  
                 perl-extutils-depends  perl-extutils-pkgconfig  perl-gnome2-wnck  perl-libintl-perl  
                 perl-locale-gettext  perl-uri  perl-xmms  perlpanel  perlxml  procinfo  vim  
Conflicts With : None
Installed Size : 30503.13 K
Packager       : Tobias Powalowski  <tpowa@archlinux.org>
Architecture   : i686
Build Date     : Mon Mar 12 18:29:03 2007 UTC
Build Type     : Unknown
Install Date   : Sat Aug  4 17:51:35 2007 UTC
Install Reason : Installed as a dependency for another package
Install Script : Yes
Description    : Practical Extraction and Report Language

All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

#4 2007-08-05 07:54:27

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

Re: [SOLVED] can't build firefox - full perl install required

OK so i just rebuild Perl from ABS and FF will build properly now...

Cheers


All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

Board footer

Powered by FluxBB