You are not logged in.

#1 2007-08-07 04:42:33

mcmillan
Member
Registered: 2006-04-06
Posts: 703

Error Checking File System that doesn't exist anymore [Solved]

I had been dual booting Arch and Ubuntu on my desktop and recently decided to ditch ubuntu and experiment with slackware. I also decided to take advantage of the reinstall to clean up my partition scheme.
The old:

sda1 ntfs windows
sda2 fat32 shared data 
sdba5 swap
sdb1 ext3 Arch's root
sdb2 ext3 Arch's home
sdb3 reiser Ubuntu home
sdb4 logical partition
sdb5 reiser Ubuntu's home
sdb6 ext3 used to be shared /boot, but only Ubuntu had been using it since last Arch reinstall

The new

no changes to sda or Arch's partions
sdb3 ext3 Slackware root
sd4 ext3 Slackware home

Slackware is working fine, but when I try to boot up Arch I can only get to where it checks the filesystem, sdb1 and sdb2 check clean, then it tries to check sdb5 and obviously isn't finding this to be clean. When it drops me to the terminal I my old partitions and sdb4 are clean. sdb3 gives me an error saying it can find the reiser journal (don't have the exact wording but it obviously thought this should be a reiserFS not ext3) but if I do fsck.ext3 instead of just fsck it says it's clean.

It's probably relevant that my last few boots before the slackware install were complaing that my ubuntu partitions weren't clean, which kind of confused me since I didn't even mount those in Arch but I didn't bother fixing it since I was planning on reformatting them when I installed slackware and I could still boot into Arch unlike now.  I'm wondering if Arch is still complaining about them not being clean from before I reformatted.

Can someone help me convince Arch to let me boot again?

Last edited by mcmillan (2007-08-07 16:23:54)

Offline

#2 2007-08-07 05:45:24

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: Error Checking File System that doesn't exist anymore [Solved]

Have you changed fstab on Arch's root partition?

Use some LiveCD (even Arch's installation CD will do) to do so.

Offline

#3 2007-08-07 16:23:26

mcmillan
Member
Registered: 2006-04-06
Posts: 703

Re: Error Checking File System that doesn't exist anymore [Solved]

That fixed it, wish I had thought of that sooner. Thanks

Offline

Board footer

Powered by FluxBB