You are not logged in.

#1 2007-08-30 00:22:51

Registered: 2007-07-06
Posts: 50

[SOLVED] Really messed up Alsa, please help (snd_hda_intel)

I receive my new Dell Latitude D830 yesterday.  I installed Arch without out much trouble.  I'm now trying to build up the machine. I've really messed up the sound.  Can anyone help?

Here's the timeline....

This is the device.  I understand the module should be snd_hda_intel.

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

I was able to follow the Arch alsa document which resulted in adding

alsa-lib, alsa-utils and alsa-oss

It seems the right module was found, by looking at lsmod|grep '^snd'.  (udev do this?)
Also, I had plenty of devices in /dev, including control and pcm.  But, NO SOUND.
Yes, everything was unmuted.

So, I went looking for solutions.  I found which said to
get a recent cvs version of alsa here … ot/driver/

So, I got it, and ran something like

./configure --with-cards=hda-intel --with-sequencer=yes ; make ; make install

Now, I can't start alsa

/etc/rc.d/alsa start
:: Restoring ALSA Levels                                                                                                                                                    [BUSY] /usr/sbin/alsactl: load_state:1327: No soundcards found...

I probably messed up my clean Arch install with the 'make install' line.  I was a bit quick with the copy/paste, I'm thinking I should have done 'make install-modules, instead.

Question:  How can I fix this?  I'm trying to find a solution that doesn't mean reinstalling Arch.  But, I don't understand how Alsa and Arch work together, so I might have to.

Last edited by ristretto (2007-08-30 01:11:19)


#2 2007-08-30 00:27:57

Registered: 2007-05-20
Posts: 1,411

Re: [SOLVED] Really messed up Alsa, please help (snd_hda_intel)

try doing "make uninstall" from the directory where you had built alsa and then remove and reinstall the arch alsa packages - if pacman complains about files that already exist just use -Sf option to force overwriting of files...
you could probably get away with just force reinstalling arch packages...
that should get you back to the status quo with working alsa but no sound.

Last edited by fwojciec (2007-08-30 00:29:41)


#3 2007-08-30 01:20:50

Registered: 2007-07-06
Posts: 50

Re: [SOLVED] Really messed up Alsa, please help (snd_hda_intel)

Thanks.  That was helpful.  Coming from Gentoo you'd think I'd of thought of that.  But, eh, portage is an abstraction above ./configure, so ... 

For anyone else, here's what I did to, not only untangle my machine, but also get sound working.  smile

1.  As was pointed out, I ran make uninstall in the alsa-driver-1.0.14 source that I had previous run make install in.
2.  I got the latest alsa-driver-hg20070828.   
3.  Ran ./configure --with-cards=hda-intel --with-sequencer=yes ; make ; make install-modules
4.  modprobe snd-mixer-oss snd-pcm-oss snd-page-alloc snd-pcm snd-timer snd snd-hda-intel soundcore  (the snd modules listed in /etc/rc.conf)
5.  /etc/rc.d/alsa restart
6.  amixer sset PCM,0 80%,80% unmute
7.  amixer sset Front,0 80%,80% unmute
8.  mpg321 I_Wanna_Be_Like_You.mp3

I think it's the latest driver that did it, and the un-borked system.  (I think there was an init 6 after step 5, but I don't think it was truely necessary.)

Learned just a bit more about my OS today.....


Board footer

Powered by FluxBB