You are not logged in.

#1 2007-09-10 09:22:51

From: Germany
Registered: 2007-08-14
Posts: 1,885

Cannot open root device

just tried doing a fresh start as i messed up my system installing kde4.

so i got the new 2007.08.1 iso and installed arch.

so on boot i get the following error message:

Waiting 0 s before mounting root device
kinit: Cannot open root device sdb1 (8,17)
kinit: kinit not found!
kernel panic - not syncing: Attempting to kill init!

so... i checked if fallback image is working.. it does!

so i compared /etc/mkinitcpio.d/kernel26-fallback.conf and /etc/mkinitcpio.conf
and guess what: they are identical except for hook "autodetect".

so i removed "autodetect" from mkinitcpio.conf and tried again: same error.

and now i am clueless what else to do... any suggestions?

Last edited by Rasi (2007-09-10 09:23:10)

He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams


#2 2007-09-10 09:54:19

Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Cannot open root device

Boot with the fallback initramfs image, and then regenerate your default image using the original mkinitcpio.conf.

The fallback image is for rescue/diagnostic purposes only, not for normal use.


#3 2007-09-14 05:12:41

From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263


Board footer

Powered by FluxBB